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Read Me First
 
Welcome to Take Control of iBooks Author, version 1.1, published 
in March 2013 by TidBITS Publishing Inc. This book was written by 
Michael E. Cohen and edited by Tonya Engst. 

This book introduces you to iBooks Author, Apple’s software for 
creating and publishing what Apple calls “Multi-Touch books.” 
Although iBooks Author was specifically designed with textbook 
publishing in mind, Take Control of iBooks Author shows you how 
to conceive, plan, produce, and publish Multi-Touch books for a 
variety of uses and audiences. 

Discounted classroom and Mac user group copies are available.
 

Copyright © 2013, Michael E. Cohen. All rights reserved.
 

Updates and More
 

You can access extras related to this ebook on the Web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and—usually— 
Mobipocket. (Learn about reading this ebook on handheld devices 
at http://www.takecontrolbooks.com/device-advice.) 

•	 Read postings to the ebook’s blog. These may include new tips or 
information, as well as links to author interviews. At the top of the 
blog, you can also see any update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 
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Basics
 

Here are a few “rules of the road” that will help you read this ebook: 

•	 Links: All blue text in this ebook is hot, meaning you can click 
(or tap) it, just like a link on the Web. If you click a link to switch to 
a different part of the ebook, you can return to where you were with 
a shortcut, if your ebook reader offers a “back” feature. For example, 
if you use iBooks in iOS to read the EPUB version of this ebook, 
you can tap the “Back to” link at the lower left of the screen. Or, if 
you use Preview on the Mac to read the PDF version of this ebook, 
you can choose Go > Back or press Command-[. 

•	 Menus: Where I describe choosing a command from a menu in 
the menu bar, I use an abbreviated description. For example, the 
abbreviated description for the menu command that displays the 
Styles drawer in iBooks Author is “View > Show Styles Drawer.” 

•	 Path syntax: This book occasionally uses a path to show the 
location of a file or folder in your file system. For example, the 
path ~/Library/Application Support/iBooks Author/Templates/My 
Templates/ leads to where iBooks Author stores any templates you 
create (the ~ means that path starts in your Home directory). 

Note: In Mac OS X 10.7 Lion and above, the Library folder in your 
Home directory is hidden by default; see Save a Template to learn 
how to access it. 

•	 Tapping: I sometimes mention tapping an item on the iPad screen, 
such as “tap the thumbnail image.” To tap, quickly put your finger 
on the item and then release your finger. 

•	 Rotate: Rotating involves turning the entire iPad 90 degrees, 
which shifts the onscreen display between the portrait (tall) and 
the landscape (wide) orientation. 
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What’s New in Version 1.1
 

This 1.1 version of Take Control of iBooks Author takes into account 
the changes and enhancements in iBooks Author 2.0 (see Apple’s 
Support document “What’s new in iBooks Author 2.0,” at http:// 
support.apple.com/kb/HT5478). The most notable revisions in the 
ebook are these: 

•	 In Import Text I added information about how to use section breaks 
in an imported document so that it imports as multiple chapters 
or sections, plus I now provide more details about importing from 
Pages or Word. I also added more help in Importing Tips. 

•	 In Choose a Template, I have taken into account the expanded 
range of templates in iBooks Author 2.0 and discussed some 
of the specialized templates that are now included. In particular, 
I describe the new Portrait Only templates in Choose between 
Portrait and Landscape Templates. In addition, I now refer to 
the portrait view in the original landscape templates from iBooks 
Author 1 as the “alternate portrait view” to distinguish it from the 
Portrait Only template. 

•	 Several options available when you Customize the Opening have 
changed. The removal of the audio option and the expansion of 
video formats for Intro Media is documented in Change the Intro 
Media. Change the Table of Contents now takes into account 
Portrait Only templates. 

•	 iBooks Author 2 adds the ability to create new chapter, section, 
and page layouts; I talk about those in Modify the Layouts. iBooks 
Author 2 also subtly modifies how much you can customize the 
alternate portrait layouts in a Landscape with Portrait template: 
I discuss that in Change an Alternate Portrait Chapter Layout and 
Change a Section Layout. 

•	 In Lay Them Out like Widgets, I describe the new Make Full Screen 
on Tap option for images, shapes, and other objects and how it 
affects the alternate portrait view. 

•	 I point you to information about adding complex mathematical 
equations with MathML and LaTeX in By the Numbers. 

6 

http://support.apple.com/kb/HT5478
http://support.apple.com/kb/HT5478
http://support.apple.com/kb/HT5478
http://support.apple.com/kb/HT5478


           
         
        

             
        

         
          

         
          

          
 

•	 iBooks Author can now use any audio and video format that 
QuickTime supports in its Media widget, so I’ve removed 
information about converting media from Add Video and Audio, 
since iBooks Author now does that for you. I also describe the new 
presentation options for audio-only Media widgets in that section. 

•	 Add Interactive Presentations now covers how to Add Scrolling 
Sidebars and Pop-Overs and updates the descriptions of the other 
widgets. 

•	 The workflow for publishing books has been streamlined (see 
Prepare an iTunes Store Package), and a method of distributing 
books, Apple’s iTunes U, has become more open (see Consider 
iTunes U). 
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Introduction
 
Introduction from Version 1.0 

Near the beginning of the final decade of the Twentieth Century, 
I found myself working at a small publishing company housed in a 
condemned building on the Pacific Coast Highway in Santa Monica, 
California. I was part of a small group called the Expanded Books 
team, and our mission was to make the first mass market ebooks. 
To be sold on floppy disk. To be read on 5-pound computers with dim 
640 by 400 resolution monochrome screens. We all wore black-and-
white “Text: The Next Frontier” T-shirts, and we felt that we were 
inventing the future. 

We were. In their heyday, the Voyager Expanded Books were award-
winning hits and the talk of the publishing world. Voyager even wrote 
a toolkit so other publishers could produce Expanded Books. The 
possibilities seemed limitless for long-form digital text. 

But by mid-decade it all went pear-shaped. Apple, which produced 
the software and hardware on which most Voyager products depended, 
began spiraling into a near-death experience, while at the same time 
a comet slamming into Jupiter helped propel the World Wide Web 
into world-wide popularity. Long-form, carefully designed ebooks were 
out, and short-form, loosely interconnected assemblages of Web pages 
were in. Ebooks survived, but just barely, a backwater of the publishing 
world that few observers regarded as being relevant. 

Finally, some ten years later, Amazon’s Kindle re-ignited interest in 
ebook publishing, and the reborn-and-on-a-roll Apple introduced a 
device called an iPhone that redefined what a handheld device was. 
After that came the iPad and its iBooks app, and suddenly ebooks 
were hits again and the talk of the publishing world once more. 

The irony was that the ebooks of 2010 were barely more advanced in 
terms of features and usability than were the original Expanded Books 
of fifteen years earlier. In some ways, they were even less advanced. 

However, early in 2012, Apple introduced a digital book production 
tool, iBooks Author, and an ebook format that provided capabilities 
far beyond what the current standard ebook formats could provide. 
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Although iBooks Author was specifically designed for producing 
textbooks, it became immediately clear to me that long-form digital 
text was finally moving beyond what the Expanded Books could do, 
and that the ebook future was looking bright again. I was excited and 
delighted. 

Now the circle is complete: back in the days when ebooks were being 
born I wrote the user guide for the original Voyager Expanded Book 
Toolkit, and now, twenty years later, here I am writing a user guide 
for its Twenty-First Century descendent. Time for a new T-shirt: 

Text: The Next Frontier Redux 

One year later. . . 

Since I wrote the preceding, Apple’s foray into interactive book 
publishing seems to be flourishing: a look at the “Made with iBooks 
Author” section of the iBookstore shows hundreds of books of various 
types and genres. At the same time, the number of devices capable 
of displaying Multi-Touch books created by iBooks Author has grown 
enormously; to date Apple has sold well over 100 million iPads, and 
the pace seems to be accelerating. Ebooks in general have completely 
disrupted the traditional publishing industry, and self-published books 
have become a force to be reckoned with. 

With the release of iBooks Author 2, Apple has taken an already 
powerful and polished tool for making interactive ebooks and 
improved it significantly. Certainly, iBooks Author is not the 
only ebook game in town, and Apple’s iBookstore is not the only 
playground, but if you are at all interested in producing an interactive 
ebook, it’s become an even better place to start. 
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iBooks Author Quick Start
 
Take Control of iBooks Author is presented in the same sequence 
you would typically follow when creating an iBooks Author ebook. 
However, there is no harm, and often great benefit, to jumping 
around so that you can explore or inform yourself about a particular 
topic. Use this Quick Start as your roadmap to the ebook-
production landscape. 

Understand Textbooks: 
•	 See What Is a Textbook? to find out what makes a textbook a 

textbook and how iBooks Author is designed for building them. 

•	 Learn How to Think about Your Book to understand the 
relationship between its main textual spine and its illustrative 
and interactive contents. 

Plan Your Project: 
•	 You should not only Assemble the Outline, but start to Collect Your 

Assets, making sure to Be on the Right Side of Rights. 

•	 It doesn’t just happen; you have to Plan for Interactivity, using the 
widgets that iBooks Author provides. 

Put It Together: 
•	 First, Choose a Template, and then, to give your book a custom 

look, learn how to Customize a Template, including how to 
Customize the Opening and Modify the Layouts. Then Save 
a Template so you can use it for other books. 

•	 The text is the thing: understand how to Format and Flow text and 
Import Text, and decide if you want to Compose in the Shell. 

Accessorize: 
•	 Learn to Wrap so that text and non-text items can live together on 

the same page, and see why it helps to Lay Them Out like Widgets. 

•	 Add Images, Shapes, Tables, and Charts to illustrate your text; Add 
Video and Audio to bring it to life, and then Add Interactivity for the 
ultimate in reader participation. 

•	 iPads can rotate and so can your book, so don’t forget to Flip It for 
a Different View. 
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•	 Add Study Questions (and Answers) to help your book’s readers 
remember what they’ve read, and Cross Reference Your Book to 
help them find their way around. 

•	 Give your readers additional information when you Create and 
Organize a Glossary with the Glossary feature. Bonus: you can also 
use it to Create Indexes. (Sound confusing? Not if you Learn How 
the Glossary Works.) 

Expose Yourself: 
•	 Before you let your book walk out the door, Fine-Tune the Table of 

Contents, Preview Your Book, and Make Advance Reading Copies. 

•	 Finally, get down to business and Obtain an ISBN. Then, wrap it all 
up when you Set Up an iTunes Connect Account (If You Need One) 
and Prepare an iTunes Store Package (If You Need One). 

11 



           
        

      

       

           
        

          

         
        

               
            

              
           

  

  

              
          

             
            
          
              

         

            
       

        
             

          
            

          

Understand the Format
 
iBooks Author 2 is a polished, powerful tool that almost anyone 
can use to create attractive, sophisticated, interactive ebooks. 
Nonetheless, it has some limitations and shortcomings. 

Among iBooks Author’s shortcomings and limitations are these:
 

• iBooks Author 2.0 produces ebooks that can be read only on
 
iPads (including the iPad mini) using iBooks 3.0 or later.
 

• iBooks Author requires a Mac running Mac OS X Lion 10.7.4 
or above. 

•	 The iBooks Author license agreement stipulates that you can 
sell books produced by iBooks Author only through Apple’s 
iBookstore. 

If none of these is a deal-breaker for you, you still need to figure out 
if iBooks Author is the right tool for building your interactive ebook, 
and to do that you need to understand what kinds of ebooks it was 
specifically designed to create, and what kinds of features it offers 
for creating them. 

What Is a Textbook?
 

iBooks Author was designed to create not just any kind of ebook, but a 
particular type of book: specifically, the ebook equivalent of a textbook. 

Ah, but what is a textbook? Even taking into account that in your 
student days you spent a lot of time reading them, carrying them 
around, and scribbling in them, your student experience of textbooks 
probably never led you to think about what they are in terms of what 
it takes to devise them, produce them, and sell them. 

Here are some of the characteristics of textbooks that, as an aspiring 
textbook author or publisher, you need to understand: 

•	 Textbooks contain course materials: That is, most textbooks 
are associated with a course taught in a class by a teacher, and they 
contain much of the subject matter of that course. Moreover, those 
materials are arranged in the textbook in such a way that a teacher 
can pick from among them to build a well-ordered curriculum 
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consisting of daily or weekly assignments. Therefore, textbooks 
usually contain many discrete identifiable sections, each of which 
is designed to be used as the basis for a lesson or group of lessons. 
Bottom line: textbooks, no matter the subject, all tend to be built 
using a common set of simple structural elements. 

•	 Textbooks contain much more than plain text: Belying its 
name, it is a rare textbook that doesn’t include pictures, figures, 
charts, and other graphic materials along with the text, and, in some 
cases, even overshadowing the text. Textbooks generally are much 
more media-rich than the typical fiction or nonfiction book that is 
marketed to the general public. 

•	 Textbooks are adopted, not sold: Even if students buy their 
own textbooks, they don’t usually get to choose which textbooks 
they purchase: that decision typically is made by someone else. 
That someone else could be a bunch of people, such as a committee 
authorized to make textbook selections for a school district, or it 
could be a single individual, such as a professor teaching a college 
course. 

iBooks Author is tailored to build ebooks—Apple calls them Multi-
Touch books—that align with these textbook characteristics as closely 
as possible. 

Multi-Touch books can: 

•	 Provide structured curricular materials: Each Multi-Touch 
book template in iBooks Author creates books that are divided 
into chapters, with chapters divided into sections (Figure 1). The 
sections and chapters are numbered by default, the way most paper 
textbooks are arranged. See Choose a Template for more details 
about the textbookish structural elements provided by an iBooks 
Author book template. 
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Figure 1: iBooks Author provides a common Chapter/Section
 
structure for textbooks, along with other standard textbook
 
elements.
 

•	 Support complex graphic materials and layouts: Every 
template has placeholder art that you can replace to provide custom 
page art. You can also add sidebar texts (described in Format and 
Flow), and a wide variety of graphic and dynamic elements, such 
as video and animations; read Add Your Assets for more. And if that 
isn’t enough, iBooks Author provides tools for building interactive 
review questions; see Add Study Questions (and Answers). 
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•	 Be adopted by individual classes or larger instructional 
organizations: Apple provides distribution channels for the 
Multi-Touch books that iBooks Author creates. iBooks Author 
can link you directly to the iTunes Connect software service that 
you use when you publish and distribute Multi-Touch books via 
the iBookstore—see Set Up an iTunes Connect Account (If You Need 
One). Apple has also added the capability to distribute Multi-Touch 
books along with other course materials to its iTunes U service (see 
Consider iTunes U). 

Apple has designed both of these distribution channels to work 
with academic institutions: the iBookstore with a volume discount 
plan for schools to purchase ebooks, and iTunes U for hosting 
free materials online for classes. 

But the Multi-Touch books that iBooks Author produces can be 
used for ebooks other than textbooks. You could build a catalog, 
or a cookbook, or even a media-rich novel. In fact, a quick look at 
the “Made with iBooks Author” section in Apple’s iBookstore shows 
a variety of non-textbook titles: movie books, art books, travel guides, 
cartoon collections, children’s books, and many others kinds of 
multimedia books. Nonetheless, what iBooks Author’s tools and 
capabilities were designed to do is to build textbooks. 

How to Think about Your Book
 

Unlike Mr. Loopner, the never-seen early Saturday Night Live 
character who was born without a spine, Multi-Touch books do have 
a spine, and that spine is made of text. That is, each page contains text 
boxes through which text flows from one box to the next and from one 
page to the next, no matter what the template. Although, as I have said, 
textbooks can, and almost always do, contain much more than text, it 
is the flowing text that is the core of a textbook, the spine from which 
all of those other elements—videos, figures, interactive quizzes, tables, 
and sidebars—hang (Figure 2). 
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Figure 2: Imagine your book as a text spine with images and other 
elements hanging from it. 

Multi-Touch books may be interactive, but they are, at bottom, very 
linear. They consist of linear sets of text-containing pages, arranged 
into linear sets of sections within linear sets of chapters, and, by 
default, iBooks Author consecutively numbers those pages, sections, 
and chapters automatically (though you can override it). 

To put the icing on the linearity cake, iBooks Author also will 
automatically number the figures, tables, and any other items that 
you’ve hung from the text spine. Those non-text elements, in other 
words, have a linear order of their own, and that order is based upon 
where they hang from the linear text spine. The spine holds them 
all together. 
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Don’t fight it: If you try to produce a sprawling, multi-branching 
hypertextual or hypermedia work, iBooks Author will resist 
you every step of the way. Don’t fight the linearity. Embrace and 
exploit it. 

When you think about it, linearity makes practical pedagogical 
sense: the last thing a student needs when confronted with a tome 
of completely unfamiliar information is to also have to figure out an 
unfamiliar system for getting at that information. The linear structure 
of a textbook, whether paper or Multi-Touch, is a stable structure, 
a comfortable structure, something solid on which a student can rely 
as she explores unfamiliar concepts and facts. 

Linearity is comfortable for the teacher, too, and it’s convenient. 
Teachers can make assignments by page number, chapter number, 
or section number, rather than having to describe to students how 
to use the software to access the materials for the assignment. 

Most importantly, from your point of view, is that you don’t have to 
devise an interface to present your content: you have one, and it’s one 
that works and that has worked for thousands of years. Instead, all you 
need to do is figure out the best linear arrangement for the materials 
you want to present. And that is no small task, because how a subject 
maps to a linear presentation is not always obvious, and the mapping 
can sometimes be arbitrary. 

Consider these examples of types of textbooks and their organizing 
principles: 

•	 History textbooks: This is a simple case, since these are usually 
presented in chronological order of historical events. 

•	 Math textbooks: These tend to have an obvious inherent linear 
structure, moving from basic concepts to more advanced ones. 

•	 Biology textbooks: These also tend to arrange themselves 
from basic to more advanced topics, but what is “basic” and what 
is “advanced” is less obvious. Do you start with cells and move up 
to larger organisms? Start with DNA and go from there? Start with 
abstract concepts (species, phyla, families, and so on) and move to 
specifics? The writers of this kind of textbook usually create some 
sort of narrative structure, their “story of biology,” and then arrange 
their topics within that narrative. 
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•	 Catalogs: These aren’t textbooks, per se, but they’re easy to 
make in iBooks Author, and some textbookish things (e.g., lexicons, 
map collections) are catalog-like. Here you can use various linear 
organizing principles: alphabetical, directional, and so on. The best 
ones are the ones the reader has to think the least about. 

The lesson to take from the preceding discussion is simple: to make the 
best use of iBooks Author, you need to visualize the subject matter you 
want to convey as a linear presentation that consists of both a central 
text and various non-textual elements attached to that central text. 

Not that hard, really. Until you get into the details… where you-know-
who lives. 

18 



          
        

            
              
         

 

           
             

             

          
          

         
 

             

              
               

             
         

            
           

              
               

             
            

          
             

            
     

               
          

Plan Your Book
 
One problem with iBooks Author is that it’s enticing: you can 
quickly use it to bang together a good-enough looking Multi-Touch 
book with not much effort, and, what’s more, it’s loads of fun to do. 
The temptation to dive in to build your book and, in the process, to 
play with all the software’s whiz-bang features can seem irresistible. 

Resist it.
 

Your book will be much better, and you’ll have a much better chance 
to finish your book, if you take time at the beginning to map out 
what you’ll be doing and to get all your virtual ducks in a row. 

This chapter looks at the admittedly unexciting but essential steps 
you should take before starting book production: making an outline 
(described just below), how to Collect Your Assets, and how to Plan 
for Interactivity. 

If you want to play the game, it helps to have a game plan.
 

Assemble the Outline
 

As a matter of full disclosure, I have to tell you: I hate writing 
outlines. When I had to do it as a student because it was part of 
a paper assignment, I often faked the outline, writing it after I had 
already composed much, if not all, of the final paper. 

When I eventually came to write books for people who would give 
me money to do it, I discovered that I wouldn’t get any money for a 
book project if I didn’t have a solid outline for the project first. Since 
I found that it wasn’t practical to write a whole book first to come up 
with the outline, I had to grit my teeth and produce one ahead of time. 
I soon discovered that a good outline will get you through those days 
when inspiration flags, and that knowing where you’re going does 
help you to get there. These days, though I still don’t enjoy the process, 
I don’t go into any book project without an outline. Fortunately, they 
don’t take that long to create. 

What do I mean by an outline? I mean any sort of written plan that 
lists the topics that you plan to cover, with enough detail about each 
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topic so that, when you write the book, you can use it as a guide. You 
don’t have to use the type of outline with “I. A. 1. a.” sorts of headings; 
your outline doesn’t even have to look like a traditional outline. All 
it needs to be (unless your editor requires a specific format) is a road 
map with enough information for you to follow it to your destination. 

A few tips to keep in mind about your outline: 

•	 Be flexible: Make sure your outline format doesn’t lock you into 
a particular arrangement too early. As you create your outline, you 
doubtless are going to discover that you’ll need to move some items 
around, delete others, and expand still others. Your outlining tool 
should not constrain you; if you have to spend time thinking about 
the mechanics of how to nest or to move items around, you’re doing 
it wrong. 

•	 Don’t go too deep: Although you need a plan if you’re not to 
go haring off in random and unproductive directions, remember 
that writing even a well-planned book is still a voyage of discovery. 
Too much detail in an outline can be as troublesome and as 
counterproductive as too little. Hit the high points, but don’t try 
to include every little thing. 

Also, keep in mind that iBooks Author encourages a shallow 
structure: as I mentioned in What Is a Textbook?, iBooks Author 
gives you chapters and sections as structural elements; however, it 
doesn’t provide subsections. That means you have only two explicit 
levels of depth that you can easily realize in a Multi-Touch book’s 
structure. Although you can manually add subheadings within an 
iBooks Author section, those don’t appear by default as part of the 
book’s table of contents like chapters and sections do (though you 
can make them appear; see Change the Table of Contents), and 
you can’t move individual pages or groups of pages around like you 
can do with sections and chapters. My best advice is to match your 
outline’s structure to the structure that iBooks Author imposes. 

Tip: The longer your chapters, the more sluggishly your book may 
perform, especially on older, slower iPad models. In the iBooks Author 
Help, Apple recommends: “To optimize the viewing experience, create 
more smaller chapters rather than fewer larger chapters.” 
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•	 Remember the instructional context: If you are writing 
a textbook, keep in mind how textbooks tend to be used: in a 
classroom, over a period of weeks, as part of a course of instruction. 
In that environment, materials are often doled out in small 
chunks, tied to a lesson plan and to specific assignments—and 
not necessarily doled out in the order of a textbook. What’s more, 
teachers or administrators may choose which parts of a textbook to 
use and which to ignore to satisfy curricular needs (this may be one 
of the reasons for the flat structure that iBooks Author imposes). 
Therefore, each item in your outline may have to stand on its own. 
Plan your book so it will be teacher-ready and classroom-friendly. 

My Outline Workflow for the Curious
 

What did I use to outline this book? Several tools: I started with 
Scrivener (http://literatureandlatte.com/scrivener.php) because I 
am familiar with the application (I helped edit Kirk McElhearn’s Take 
Control of Scrivener 2) and because it provides a rich assortment of 
features for constructing and rearranging outlines. 

My Scrivener outline consisted of the book’s planned chapter and 
section titles, with a short prose synopsis attached to each one. Each 
synopsis comprised a list of the items I wanted to cover in that part 
of the book, notes about points I wanted to emphasize, possible ways 
to arrange the material, and so on. 

Then I exported a rough version of the outline into Google Docs so 
Take Control co-publishers Adam and Tonya Engst could play with it. 
Next, I exported the revised outline from Google Docs to Microsoft 
Word format and imported that file into Pages (Google Docs doesn’t 
export directly to Pages, but Pages can eat Word files with ease). 

Once the outline was in Pages, I took it apart. I copied each outlined 
topic individually from the outline document and pasted it into the 
canned Pages document that Take Control authors use to begin each 
ebook. I styled each chapter and section heading with the appropriate 
Take Control style in my Pages manuscript, and I attached each 
synopsis from my outline as a comment to its heading in the 
manuscript so I could refer to it as I worked. 

Tip: If you plan to import text from Scrivener into iBooks Author, 
read the blog post by Keith Blount, Scrivener’s developer, at http:// 
www.literatureandlatte.com/blog/?p=265. 
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Collect Your Assets
 

By assets I don’t mean your investments, personal belongings, or 
vacation home on Maui (though if you have one, I am available to 
house-sit—call me). I’m talking about the non-textual items that 
you want to include in your Multi-Touch book: images, videos, audio 
recordings, and the like. You may use some of these assets as direct 
accompaniments to your text (such as figures, photos, charts, and 
maps); others you may use as components of interactive elements 
that you devise to accompany the text (see Plan for Interactivity, ahead 
in this chapter). At the very least, you’ll likely need cover art and an 
introductory media element for beginning each chapter and section. 

While you may produce some of these items yourself, in my experience 
multimedia projects eat media like a couch potato eats Cheetos, and it 
is an unusual multimedia project that contains only original and non-
rights-encumbered media assets. That means you are going to have to 
beg, borrow, and, if necessary, buy the ones you need. 

Your media assets are (or should be) as integral to your book as the 
text, and their inclusion requires just as much planning—in fact, it 
often requires more. I can give you some general, hard-won advice: 

•	 Don’t wait: Because media assets can take time to prepare or 
procure, the time to start compiling a list of the ones you need is 
at the beginning. When you add a topic to your outline, consider 
how you will illustrate it and include that description in your 
outline. Which brings me to the next point... 

•	 Track everything: Create a separate document, perhaps in 
Numbers or Excel, to track your assets. For each media asset 
you hope to include in your book, you should track the following: 

‣	 Description: If it’s a photo, describe what it depicts. If it’s an 
audio or video recording, include the title, format, and length. 
Include whatever information you need to keep yourself from 
asking weeks later, “What the heck is this thing again?” 

‣	 Purpose: Where and how you think you’ll use it in your work. 
Note whether it is an illustration or part of an interactive 
presentation. This information should also be in your outline. 
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‣	 Source: Where you can obtain it. This might be yourself, an 
artist friend, a stock house for images, an archive or museum, 
or some other source. Include the information you need to 
contact the source. 

‣	 Price: How much it will cost to obtain. If your project has a 
budget, and most do, this is essential information. 

‣	 Rights: List the kind of rights attached to the item. Some assets 
may be completely free to use (such as public domain images), 
but many others will have limitations, including restrictions on 
the number of copies you can make, specifications for how you 
can use them, and so on. See Be on the Right Side of Rights, later 
in this chapter. 

‣	 Status: Record if you have the asset, if you are waiting for it, if 
you are still negotiating to obtain it, and so on. 

•	 Ask for help: Although some publishing houses put the onus 
of securing assets and their rights directly on the author, others 
maintain staff who specialize in these issues. Colleges and 
universities often have a department or organization that helps 
faculty authors keep from running afoul of rights and permissions 
issues. Librarians are sometimes an excellent source to help you 
track down media assets. Whatever your situation, don’t go it alone 
if you don’t have to. 

•	 Plan for failure: The philosophers Jagger and Richards have 
taught us that you can’t always get what you want, but if you try 
sometimes, you might find you get what you need. Unless your 
needs are small or you are lucky (or both), the chances are good 
that you won’t be able to obtain every media asset you want. Give 
yourself fallback positions: if you can’t obtain the iconic photo you 
want, maybe you can find another that does almost as well; if you 
can’t get the video you want, maybe you can obtain still images or 
another video that provides similar illustrative power. Be flexible; 
give yourself wiggle-room. 

Don’t box yourself in: If your book absolutely relies upon the 
inclusion of a specific media asset for which you don’t have the 
rights, you are asking for failure. Always have an alternative. 
Remember that your readers will never know what you intended 
to include in your book; they’ll only see what you did include. 
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Be on the Right Side of Rights
 

Copyright law can be complicated, but you don’t have to have all of 
Nimmer on Copyright (http://www.worldcat.org/oclc/4514674) under 
your belt to understand and follow one basic premise: if you don’t 
have the rights to use a copyrighted work in your book, don’t use it. 

And what is a copyrighted work? Just about anything that you 
can put in a Multi-Touch book: text, image, audio, video. From the 
moment a work of any sort is created, it is copyrighted, whether a 
copyright has been formally filed for it or not. This text, as I type it, 
is protected by copyright. 

And what does copyright protect? It protects the copyright owner’s 
right to control who copies the work or any portion of it. The 
copyright holder can assign rights to copy the material to others, 
and the holder can even assign the copyright itself to someone else. 

But, not all works are copyrighted: a copyright expires after a time. 
Currently, in the United States, a written work’s copyright expires 
70 years after the author dies; the copyright term varies for older 
works, other types of work, and works of corporate authorship. 
Generally, to be safe, it’s a good bet that if a work was written, 
photographed, drawn, or recorded within the past 100 years, it is 
protected by copyright. 

Granted, there is such a thing as the public domain (http:// 
en.wikipedia.org/wiki/Public_domain), and works in it are free to 
be copied, and there are also licenses, such as Creative Commons 
(http://creativecommons.org/) licenses, that allow for copying (with 
restrictions) of some works. Still, unless you know for a certainty that 
a work is in the public domain, or that you have the right to use it 
under a Creative Commons license, don’t use it without permission. 

Luckily, you can often obtain the right to copy a work or portion 
of it, either by paying for a license, or by asking for, and receiving, 
permission. Sometimes, all it takes is a letter to the copyright holder 
to obtain permission, especially when the use is for instructional or 
nonprofit use. In certain cases, even if you don’t have permission, 
the doctrine of Fair Use (http://www.copyright.gov/fls/fl102.html) 
may protect you—but don’t count on it. When in doubt, ask. Get the 
rights. You’ll sleep better at night. 
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Plan for Interactivity
 

As I said in Collect Your Assets, some of the media assets that you 
acquire will end up as components of the interactive elements that 
accompany your text. iBooks Author calls these interactive elements 
widgets, and it provides a nine-pack of them in its Widgets menu 
on the Toolbar (Figure 3). 

Figure 3: The nine interactive widgets found on the Widgets menu. 

Six of these widgets you can think of as ways to interactively illustrate 
your main text; two of them provide ways to expand upon the main 
text; and one of them, Review, is a study aid. 
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These interactive widgets are available to enrich and supplement 
your text. Used effectively, they can add life and energy to your book. 
However, a widget can take significant time and effort to produce and 
polish, and too many of them can distract your readers from the main 
content of your book. Like any spice, they usually produce the best 
effects when used sparingly. 

Here are capsule descriptions of each widget along with example 
images taken from this book’s Multi-Touch companion book, Take 
Control of Getting Ready for iBooks Author, where the examples are 
fully functional (see the sidebar Try These Widgets in a Multi-Touch 
Book): 

•	 Gallery: If you have a set of pictures that you’d like readers to 
compare (say, a biology book with photos of a bacteria or mold 
culture growing over time), use this. Readers can flip through the 
images, and you can provide a caption for each image (Figure 4). 

Figure 4: An example of a Gallery widget. 
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•	 Media: For video or audio illustrations, this is the widget you use 
(Figure 5). In a Multi-Touch book, your reader gets the standard 
iPad player controls for video or audio playback. You can specify 
start and stop times and some other display options for media 
presented by this widget. 

Figure 5: A Media widget example. 

I explain more about using and optimizing playable media in Add 
Video and Audio. 
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•	 Review: To present your reader with a short set of interactive 
study questions, the Review widget provides several multiple choice 
and dragging questions (see Figure 6 for an example). 

Figure 6: A Review widget example. 

You can mix the types of question used in a review widget. As 
the name suggests, the review widget is not a testing mechanism 
(it doesn’t store the results for a teacher to check and record later), 
it merely helps the reader review the material being presented. The 
questions presented by a review widget are a good way to reinforce 
the main concepts in a section or chapter. 

I describe how to use this widget in Add Study Questions (and 
Answers). 
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•	 Keynote: To illustrate your text with Keynote presentations, 
you use the Keynote widget. You can also use this widget for 
PowerPoint presentations—if you convert them to Keynote format 
first. Much has been written about the limitations and dangers 
of such presentations (a Web search for PowerPoint considered 
harmful is enlightening), but the bullet-point-with-illustrations 
slideshow format nonetheless can be a useful review and summary 
tool. The widget can display only Keynote presentations that 
have been converted to HTML, although iBooks Author will do 
the conversion automatically if Keynote is installed on your Mac. 

Presentations can display in the page or in full-screen, and they can 
have optional navigation controls (Figure 7). 

Figure 7: A Keynote widget example. 

I discuss how to use this widget in Add Keynote Presentations. 
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•	 Interactive Image: To allow students to zoom around an image 
and view points of interest you have labeled, choose the Interactive 
Image widget. You might use this for interactive maps, visual 
tours of a historic site, identifying the parts of a flower, and so on. 
The widget also provides optional navigation controls (Figure 8) 
and the capability to provide extended descriptions in an optional 
sidebar overlay. 

Figure 8: An example of an Interactive Image widget. 

Skip ahead to Add Interactivity for details about how to set this 
widget up and use it. 
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•	 3D: If you need a scalable, rotatable model of something, such 
as a molecule or a machine part, you can use the 3D widget, which 
displays COLLADA format 3D models (http://en.wikipedia.org/ 
wiki/COLLADA) as shown in Figure 9. 

Figure 9: A 3D widget example. 

Many 3D rendering programs can produce COLLADA files (they 
have a .dae file extension, should you happen to run across one). 

Read Add 3D Objects to see how to put a 3D model in your book. 
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•	 Scrolling Sidebars and Pop-Overs: Print textbooks often have 
sidebars. A sidebar usually appears as a box set off from the main 
text, often in a different typeface and with a different background 
color to distinguish it. In print books, sidebars tend to be short, 
rarely taking up a full page, and the book’s main text flows around 
them. This layout technique lets the reader know that the content 
in the sidebar is a digression from the main content. 

iBooks Author has a Scrolling Sidebar widget (Figure 10) that can 
present such ancillary but interesting information to accompany 
your book’s main text. Like a print-book sidebar, a Scrolling Sidebar 
can include images and shapes and even embedded text boxes. 
Unlike a print sidebar, however, the dimensions of a Scrolling 
Sidebar don’t limit what it can contain, because readers can scroll 
through it. 

Figure 10: Example of a Scrolling Sidebar widget with scrollbar 
showing. 

Another way to satisfy your readers’ hunger for additional 
information is with a Pop-Over—no, not the baked good (that’s 
a popover without the hyphen) but a widget that pops text and 
images over the page. 

Pop-Overs are anchored to an image on the page, such as the 
picture of a baked popover shown in Figure 11. When the reader 
taps the image, the Pop-Over pops up. Like a Scrolling Sidebar, 
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a Pop-Over widget can contain a good deal of text—as well as 
images, shapes, and embedded text boxes. A Pop-Over can scroll 
like a Scrolling Sidebar can, too, so you can load a Pop-Over with as 
much content as you need. Remember, though, that unless you let 
your readers know that the image anchoring a Pop-Over is active, 
they may assume that it is just another graphic sitting on the page. 

Figure 11: An example of a Pop-Over widget with an image of 
a popover as its anchor. 

Find out how to add these two text-expanding widgets in Add 
Scrolling Sidebars and Pop-Overs. 
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•	 HTML: In case none of the other widgets provide quite the 
illustrative or review capabilities you need, and you have basic 
programming chops, you can use an HTML widget (Figure 12). 
This widget doesn’t accept any old HTML, though: it must be 
HTML that is packaged in a Dashboard-compatible widget. 
Dashcode, a part of Apple’s free Xcode developer tool suite (http:// 
itunes.apple.com/us/app/xcode/id497799835), can produce such 
files, and a number of other applications can as well. 

Figure 12: An example of a dynamic HTML widget. 

As the wide range of available Dashboard widgets demonstrates 
(see, for example, Apple’s collection of widgets at http:// 
www.apple.com/downloads/dashboard/), you can do simulations, 
calculations, animations, and much more in a Dashboard widget. 
These widgets, however, do not provide their interactive capabilities 
directly on the page of a Multi-Touch book: the reader must tap the 
widget, at which point iBooks presents the widget in full-screen so 
that the reader can interact with it. 

I discuss the care and feeding of HTML widgets in Add HTML. 
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Try These Widgets in a Multi-Touch Book
 

This book has a free companion book, Take Control of Getting Ready 
for iBooks Author. It contains versions of a few chapters from this 
ebook, including the chapter you are now reading. However, Take 
Control of Getting Ready for iBooks Author was created in iBooks 
Author and exported in iBooks format, meaning, of course, that it 
can be read only on an iPad in Apple’s iBooks app. The version of this 
chapter in Take Control of Getting Ready for iBooks Author includes 
the functional widget examples from which the figures in this chapter 
were captured: you can play the video, interact with the interactive 
image, spin the 3D image, and so on. 

If you are reading this ebook on your iPad, you can tap the following 
link to download the 9.7 MB Take Control of Getting Ready for iBooks 
Author Multi-Touch book: 

http://www.takecontrolbooks.com/resources/0132/ 
TCoGettingReadyforiBooksAuthor-1.1.ibooks 

Safari on your iPad may show a blank screen during the download, 
so keep in mind that the 9.7 MB file may take a few minutes to 
transfer over a typical Internet connection (or longer on a slow 
connection). Once the file is downloaded, tap “Open in iBooks” (or 
“Open in”) to transfer the file to the iBooks app. Switch to the “Plan 
Your Book” chapter to view the “Plan for Interactivity” topic. 

If you are reading this ebook on a Macintosh or Windows computer, 
you can also use the link above to download Take Control of 
Getting Ready for iBooks Author. It will download to your usual 
Web downloads location. To read the ebook, you must transfer it 
to an iPad: in iTunes, choose File > Add to Library and then, in the 
Add to Library file window that appears, navigate to the book, select 
it, and click Open. Next, select your iPad in iTunes, click the Books 
button on the button bar near the top of the window, and then 
make sure Take Control of Getting Ready for iBooks Author has a 
checkmark by it so that it will copy to your iPad next time you sync. 

We distribute Take Control of Getting Ready for iBooks Author on 
the iBookstore, so you should be able to download it for free from 
the iBookstore as well. 
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Write Your Book
 
And then a miracle happens and one day you wake up and the 
elves have written it. 

No, I won’t cover the mysterious, ineffable process of writing nor 
whether elves have anything to do with it, but I will discuss the 
mechanical basics. After a look at how to install iBooks Author, 
I help you Decide Where to Compose, with a look at the pros and 
cons of writing directly within the iBooks Author interface, and, 
similarly, the pros and cons of writing in your favorite writing 
environment and then importing your finished (or almost finished) 
text into iBooks Author. And, if you decide to import your text, 
I offer important advice on how to handle formatting and styling. 

I next turn to a central task in making a Multi-Touch book when 
I describe how to Choose a Template, with guidance about how 
to Choose between Portrait and Landscape Templates, and then 
describe how to Customize a Template, including how to modify 
the different layouts that comprise a template, and how to Make 
Placeholders. 

Finally, in Format and Flow, I explain how your text flows from 
one column to the next and from one page to the next, and offer 
you options for customizing that stream, including how to Create 
a Stand-alone Text Object or Shape, pointers for how to Format 
Text, and an explanation for how to Use Updating Text to insert 
certain elements, such as automatic page numbers. 

You have to provide the text-writing elves yourself.
 

Get iBooks Author
 

Before you can perform any magic with iBooks Author you need to 
have a copy of it on your Mac. You can obtain a free copy of it from 
the Mac App Store from your Internet-connected Mac: 

1. Choose Apple  > App Store. 

36 



            
            

              
  

          
   

            

             
 

         
          

   

          
         

           
 

             
   

           
              

             
            

            
            

      

        
           

          
           

            

2. If you’ve already signed into the App Store on your Mac with an 
Apple ID, go to the next step; otherwise, do one of the following: 

‣	 If you have an Apple ID, choose Store > Sign In, and then follow 
the sign-in instructions. 

‣	 Choose Store > Create Account, and then follow the instructions 
for creating an account. 

3. In the Search field at the top-right of the App Store window, type 
iBooks Author. 

4. In the list of hits that appears, on the one for iBooks Author, 
click Free. 

5. Click Install App, and provide your password when requested. 
The App Store downloads iBooks Author and presents its icon 
in your Mac’s Launchpad. 

6. Open Launchpad and then click the iBooks Author icon in 
Launchpad to launch it. (Or, open iBooks Author in whatever 
way you prefer to open Mac applications—you’ll find it in your 
Applications folder.) 

And with that easy but essential step out of the way, let’s get started 
on making a book. 

Decide Where to Compose
 

No, I’m not talking about deciding which room you write in and which 
chair you sit in while you do it. I’m talking about whether you want 
to work directly within iBooks Author as you compose the text of your 
book, or whether you want to do your writing with the word processing 
software you normally use and then import the text into iBooks Author 
for layout, editing, and tweaking. There is no right or wrong decision 
here: each strategy has its advantages and disadvantages. 

Composing your Multi-Touch book probably will consume more time 
than will customizing your book’s appearance, but I don’t have nearly 
as much to say about the composing process. Mechanically, you have 
two choices: write within iBooks Author, treating iBooks Author as a 
word-processor, or import the bulk of your text into a prepared iBooks 
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Author template and fine-tune it. I talk about the pros and cons of each 
option next, and I offer important tips for working effectively. 

Compose in the Shell 
Here are some of the advantages of composing your book directly 
within iBooks Author: 

•	 It’s WYSIWYG: You get a clear idea of what your book will 
look like as you go, courtesy of the What You See Is What You Get 
environment. If seeing what your work will look like to your readers 
is important as you write, writing directly in iBooks Author is the 
only way you can do it. 

•	 It’s interactive: As you write in iBooks Author, you can also start 
embedding your interactive illustrations (see Add Your Assets). If 
your text needs to refer in detail to your book’s interactive features, 
it is helpful to see and try them as you write. 

•	 It’s testable: As you work you can see not only what your book 
may look like, but you can actually try it on an iPad at any time, 
using the Preview feature (see Proof and Fine-Tune). 

On the other hand, iBooks Author is not designed for collaboration. 
It offers no capability for tracking changes or for commenting on the 
text. Moreover, only one person can work on the book at a time, so 
if you have co-writers, the logistics of passing the One True Book-in-
Progress file around can be troublesome and inefficient. 

Also, unless you are familiar with Apple’s Pages word processor, you’ll 
have to take some time getting up to speed with iBooks Author. Nearly 
all the word processing commands and tools in iBooks Author are 
identical to those in Pages, and they usually work in the same ways 
(one might suspect that Pages and iBooks Author share many of the 
same software components). If you know Pages, you have a head start; 
if you don’t, you have a learning curve to climb. 

Here’s some advice for anyone who is about to start writing directly 
within iBooks Author for the first time: 

•	 Make backups regularly and frequently: Yes, your Mac is 
very reliable, but when you write in iBooks Author, all your eggs, 
as it were, are in one basket: your text, interactive illustrations, 
study questions, and glossary are all stashed within a single file 
(well, package really, but let’s not quibble). It would be a shame 
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if something happened to it—so don’t let it. (Take Control of 
Backing Up Your Mac can help you devise good backup practices.) 

•	 Stay focused: With all the interesting and attractive capabilities 
that iBooks Author offers, and the proclivity of many writers to 
look for procrastinatory excuses, you might find yourself spending 
inordinate amounts of time trying iBooks Author features instead 
of writing. Don’t get distracted: when you are supposed to be 
writing, write. 

•	 Give yourself time to play: In direct contradiction to what I 
just said, you do need to spend nontrivial amounts of time trying 
features in iBooks Author so you can see how they work—and don’t 
work. Particularly at the beginning of your first project, you should 
budget ample time for what I call productive fooling around (I 
don’t always say fooling). Make two or three sample books that you 
don’t care about to use for experiments in functionality and design, 
and then mess them up in as many interesting ways as you can. 

To summarize: if you are writing your book by yourself, are familiar 
with Apple’s Pages word processor, and feel a strong need to see your 
book come to life as you write, composing your book directly within 
iBooks Author is a reasonable way to go. 

Import Text 
Just as you don’t need a printing press and bindery to write a book, 
you don’t need to write within iBooks Author to write a Multi-Touch 
textbook (although, of course, you will need it to assemble and publish 
the final work). 

Here are some good reasons to do the bulk of your writing outside of 
iBooks Author: 

•	 Less distracting: iBooks Author has much attractive, distracting 
eye-candy to keep you from your task—tools, sidebars, Inspectors, 
all screaming click me, please! On the other hand, the current 
generation of writing tools, such as Pages or Scrivener (http:// 
www.literatureandlatte.com/), have special full-screen modes that 
eliminate most distractions. If you need a distraction-free writing 
environment, using one of those writing tools is the way to go. 

•	 Collaborative possibilities: As I remarked a page or so earlier, 
iBooks Author does not lend itself to collaborative workflows. If 
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you need to work with one or more co-writers, you may prefer 
working with Google Drive or another system that enables multiple 
people to work on the same document at the same time. 

•	 Access to tools and resources: While iBooks Author is 
exquisitely tuned to produce Multi-Touch textbooks, it has few 
facilities for managing the research and ancillary materials that 
writing a textbook usually entails. If your access to materials goes 
beyond mining what’s available in iBooks Author’s Media browser, 
a writing tool like Scrivener, which provides the capability to store, 
organize, and access a wide range of research and other materials 
in addition to its capabilities as a word processor, may be where 
you want to do the bulk of your writing. 

If you write in an environment other than iBooks Author, you can 
bring your text into your Multi-Touch books in two ways: 

•	 Import: You can import documents stored in Pages format (.pages 
files) or Word format (.doc or .docx files). To import a document, 
you can either choose Insert > Chapter from Pages or Word 
Document or drag the document into the iBooks Author sidebar 
from the Finder. 

•	 Copy and paste: You can copy text from any source to your 
Mac’s clipboard and then paste it directly into the iBooks Author 
document. Pasted text appears in the default font family that is 
assigned to the text object into which you paste it rather than in 
the same fonts as the source. 

Before you start copying and pasting or importing, however, you 
should consider what will become of your styles. And, if you import, 
you should give some thought to whether your chapters should be in 
one huge document or in a series of smaller files. (See How Much to 
Import at Once, a few pages ahead.) 

Let iBooks Author handle your fonts! When you import or copy 
and paste, some formatting may be lost. In addition, any font families 
you use that aren’t available on the iPad are substituted. Therefore, 
don’t spend much time on styling your text as you write it; instead, 
format the text after you bring it into iBooks Author. 
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When You Import Styles 
When you import text from a Pages or Word document, whatever 
styles you used in that document can be imported as well. However, 
passages of text that have styles with names matching those in 
the iBooks Author template you are using don’t take on the iBooks 
Author styles’ look. Instead, the text appears as it did in your original 
document, and the styles have red arrows by their names in the 
iBooks Author Styles drawer (similar to the Styles drawer in Pages). 
The red arrows indicate that the text’s appearance overrides the 
template’s style. 

Note: If the Styles drawer is not visible, choose View > Show Styles 
Drawer (Command-Shift-T). 

You can use the Styles drawer to revert to the iBooks Author style or 
to redefine it to match the look in your source document (Figure 13). 

Figure 13: Options for a style that has been overridden upon import 
(note the red triangle). 

Tip: To change all occurrences of an overridden style to the iBooks 
Author template’s defaults within a chapter or section, place your 
cursor in a passage that has the overridden style, choose the Select 
All Uses item in the Styles drawer’s pop-up menu, and then choose 
Revert to Defined Style. However, when you revert to a defined style, 
you lose any typeface variants within the text, such as italic or bold. 
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You may also find that a style you created in your source document, 
like, say, Quotation, should use a style supplied by the template 
instead, like Quote. Here’s how to do that conversion after you import 
your text: 

1. Click anywhere in a run of the style that you want to change, such 
as Quotation. 

2. In the Style drawer, click the down triangle to the right of the 
selected style’s name, and then, in the menu that appears, choose 
Select All Uses of style name. 

3. In the Style drawer, click the style you want to use instead, such 
as Quote. The appearance of the selected text takes on the newly 
selected style’s appearance, with typeface variants preserved. 

Note that you have the option of discarding styles when you import; 
typeface variants like bold and italic are still imported, but the named 
styles are dropped—everything comes into iBooks Author using the 
default body style for the template. 

Tip: Import the same document into two or more different layouts 
if you want to see how those layouts look with real text. 

How Much to Import at Once 
You can import no matter if your book is all in a single file or if each 
chapter is in its own file; however, how you proceed depends on how 
you have stored your Word or Pages source documents. 

iBooks Author imports Pages or Word documents into one or more 
new chapters or sections, using the layout of your choice (Figure 14). 
The import process uses section breaks in the original document to 
break it up into chapters or sections in iBooks Author’s sidebar. (Don’t 
worry if you don’t know what a layout is at this point; Modify the 
Layouts, later, describes what they are and how you use them. For 
now, think of them as sets of page designs provided by iBooks Author.) 

42 



    

        

        
            
          

        

           
           

          

       

Figure 14: Choose a layout and optionally discard styles. 

Here are two ways to handle importing your book: 

•	 Source document contains your entire book: Pick a chapter 
layout in the Pick a Layout for Imported Content dialog, and iBooks 
Author imports your book, creating a new chapter whenever it 
encounters a section break in your source document. 

•	 Each chapter is in a separate file: Pick a section layout from 
the dialog and during the import iBooks Author creates a new 
section whenever it encounters a section break in the source. 

See Importing Tips for more detailed import strategies. 
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How I Created This Ebook
 

For both the Multi-Touch companion to this book and this book itself,
 
I wrote my text outside iBooks Author. You can read the sidebar My 

Outline Workflow for the Curious, earlier, to find out how I began the
 

project with an outline in Scrivener. Once the outline was approved,
 
I composed the text in Pages. As I neared the end of the first draft,
 
several editors read the file in Pages, and we collaboratively used 

Pages’ Change Tracking and Commenting features to discuss the text.
 

With the Pages manuscript completed, the Take Control production 
team created this ebook from Pages, using Pages’ PDF and EPUB 
export features in our custom—and ever-evolving—production 
process. A MOBI version was also produced for Kindle users. The 
finished book was then made available for sale on the Take Control 
Web site, the Amazon Kindle store, the O’Reilly Media Web site, and 
Apple’s iBookstore. 

And what about Multi-Touch version? Although we didn’t produce this 
book in iBooks Author, we did produce a related book: Take Control 
of Getting Ready for iBooks Author. To do that, I copied the first few 
chapters of it into iBooks Author so I could reformat them for a Multi-
Touch book. We then prepared it as described in Prepare an iTunes 
Store Package and used an iTunes Connect account to upload the 
file to the iBookstore. We also made the ebook available as a free 
download from the Web. (Flip back to Try These Widgets in a Multi-
Touch Book to learn how to download that ebook.) 

Choose a Template
 

Every Multi-Touch book that iBooks Author produces starts from 
a template. Notably, unless you have changed iBooks Author’s 
defaults, it doesn’t make a difference whether you choose File > New 
(Command-N) or File > New from Template Chooser (Command-
Shift-N): the result is the same—iBooks Author presents you with the 
Template Chooser (Figure 15). 
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Figure 15: Every book begins with a template, and iBooks Author 
has 15 to choose from—though you can add others. 

Choose between Portrait and Landscape 
Templates 
The first choice you make is your book’s default orientation. You may 
have noticed in Figure 15 that the templates in iBooks Author 2 come 
in two varieties: Landscape with Portrait and Portrait Only. Figure 16 
gives you a slightly closer look at what iBooks Author offers. 

Figure 16: Templates, wide and tall. 
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A look at those choices makes clear that the Landscape with Portrait 
templates are iBooks Author’s favorites: this category provides three 
times as many templates as does the Portrait Only category. That’s not 
surprising when you consider that Landscape with Portrait was the 
only kind of template offered in iBooks Author 1. 

Landscape with Portrait templates provide pages wider than they are 
tall, and usually present the text and graphics in a two-column spread; 
the Portrait Only templates provide pages that are taller than they 
are wide. 

Figure 17 shows sample section opening pages from each kind of 
template. 

Figure 17: Landscape page (top) from the Classic template and 
Portrait page (bottom) from the Modern Basic template. 
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In the remainder of this section, I describe how to use a Landscape 
with Portrait template because that kind of template provides the most 
customization options. Don’t worry: just about everything I describe 
also applies to Portrait Only templates, and, when it doesn’t, I point 
that out. 

The template I use most often to illustrate how to adapt and revise 
a template is the Craft template. I’ve chosen it because that template 
provides a robust set of text and image placeholders, and, as you find 
out very shortly, playing with placeholders is a big part of customizing 
an iBooks Author book. 

You can’t tell a template by its cover: The book covers shown 
in the Template Chooser can be misleading since they might lead you 
to think that you must choose the template depending on the subject 
matter you intend to cover. That’s not necessarily so; the title that 
appears on a book cover in the Template Chooser is merely a sample 
to give you a quick impression of that template’s visual design and 
may have little to do with the kinds of content that it can handle. 

Meet the Book Elements 
What every template provides are a set of book elements, and every 
template, no matter how it looks, provides the same ones. Where 
templates differ are in their visual designs and in the layouts provided 
for some of their elements: layouts are designs that you can modify 
and apply to certain book elements (see Modify the Layouts for more— 
much more—about layouts). 

When you create a new book by choosing a template, iBooks Author 
presents its main window, with a set of toolbars at the top, a content 
work area to the right, and a Book sidebar to the left. The individual 
book elements appear in that sidebar (Figure 18). 
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Figure 18: A new book, with its elements in the Book sidebar at left. 
This book uses the Craft template. 

Here are the book elements that appear in a newly created Multi-
Touch book: 

•	 Book Cover: This is the cover of your book, as it appears on the 
iPad. The label it has in the Book sidebar in iBooks Author is the 
title you give the book; “Book Title” is the default name of every 
new book. See Change the Book Cover. 

•	 Intro Media: An optional element, it is the first thing the reader 
sees, or hears, when the book opens. It can display a picture, or play 
a video. See Change the Intro Media. 

•	 Table of Contents: This automatically generated element enables 
readers to navigate the book. See Change the Table of Contents. 

•	 Glossary: You can add terms and definitions to this optional 
element. If you don’t add any, though, the Glossary won’t appear 
in the published book. See Create and Organize a Glossary. 
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•	 Chapters: By default, a book starts out with one chapter, which 
contains one section, which, in turn, contains one page. You can, 
however, create a book which consists only of sections and pages, 
or one that consists only of chapters and pages, but no sections. 
You can’t create a book that contains only pages. The titles of 
the chapters (if any) and sections (if any) appear in the Table 
of Contents. Ordinarily, your book will contain chapters that are 
subdivided into two or more sections. See Modify the Layouts, 
Compose in the Shell, and Import Text. 

•	 Sections: These are usually contained within chapters, although 
you can add them outside of chapters as well. Most templates have 
certain specialized section layouts, such as a copyright page layout 
or preface layout, that you might want to place outside of a chapter. 
See Modify the Layouts, Compose in the Shell, and Import Text. 

•	 Pages: These contain the bulk of the text of your book. As you add 
text to your book, pages are automatically generated. You can adjust 
the layout of individual pages or groups of pages. See Modify the 
Layouts, Compose in the Shell, and Import Text. 

Tip: You can preview your book at any stage of development on an 
iPad that’s connected to your Mac. I describe how to do this in (where 
else?) Preview Your Book. 
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About Book Elements and Organization
 

The arrangement of the book elements in the sidebar controls the 
organization of your book. The first three book elements described in 
Meet the Book Elements always appear in the same order, and there’s 
never more than one of each: the cover always appears first, the 
intro media (if any) always comes next, and that’s always followed 
by the Table of Contents. (Ignore the Glossary for now; it’s special.) 

It’s when you go below the line in the sidebar that the organizational 
fun begins. The area below that line is where your book’s individual 
chapters, sections, and pages appear, and it’s where you go when 
you want to tinker with how your book is arranged. Although you 
start with only one chapter, section, and page when you create a new 
book, that quickly changes: these three types of book elements are 
the ones that contain your book’s content, and you can have as many 
of each of them as you require, creating and deleting them at need 
(to add any of these elements, select the element in the sidebar 
under which you want the new element to appear, and then choose 
an element type from the Insert > Pages command; delete elements 
by selecting them in the sidebar and pressing Delete). 

Most importantly, in terms of your book’s structure, the chapter and 
section elements can be moved around: you can drag a section from 
one chapter to another, or from one place in a chapter to another, 
or even move it outside of a chapter to stand on its own, and the 
pages it contains go with it. Similarly, you can move a chapter from 
one place to another in the sidebar, and all the sections and pages it 
contains move with it. 

What you can’t reorganize is the order of pages within a section or 
chapter. That’s because pages are designed to hold text that flows 
from one page to the next, and this text flow is what dictates the 
order of pages in a chapter or section (see Format and Flow). 

If you have done as I suggested in Assemble the Outline, the 
chapters and sections in your book should correspond to the items 
in your book’s outline. If the outline needs reorganization at any 
time while you are creating the book (and, chances are, it will), you 
can drag the chapters and sections in the sidebar to reflect the new 
arrangement. 
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Customize a Template
 

On the following pages, I walk you through the details of customizing 
a book’s template to suit your needs: the good news is that iBooks 
Author gives you much that you can customize. The bad news is that 
this flexibility means that there are a lot of details to absorb, and 
it can be overwhelming at first. However, you don’t have to do all your 
customizing before you start writing your book. You can customize 
your book’s appearance at any time. Write and customize at the pace 
and in the order that works best for you. 

You might also do what I did when I first encountered iBooks Author: 
spend a day or two making a “throw-away” book so you can play 
around with iBooks Author. And, in case anyone asks, playing that way 
is working. So don’t feel guilty if you end up having fun in the process. 

Customize the Opening 
You can customize the first three items that appear in the Book 
sidebar: the book cover, the intro media, and the table of contents. 
I cover each of them separately. 

Change the Book Cover 
When you click the top item in the Book sidebar, the book’s cover 
appears in the main working area of the iBooks Author window. No 
matter which template you choose, you will want to modify the cover 
if for no other reason than to put your title and author name on it. 

Tip: It may be that you want to get rid of the template’s book cover 
and its various pieces immediately, and supply one all of your own. 
You absolutely can do that; read on to find out what those various 
pieces are that you’ll be discarding. 

What follows may seem like a bit of work, but if you have the pictures 
you want already on hand, modifying the cover takes only a handful 
of minutes. They’re minutes well-spent, too, since an automatically 
created thumbnail version of the cover is what your reader sees when 
browsing the bookshelves in the iPad’s iBooks app or the iBookstore, 
and the full-size version is what the reader sees when the book first 
opens in iBooks. Make your cover distinctive and easy to recognize in 
the reduced thumbnail size provided in iBooks’ bookshelf display and 
in the iBookstore. 
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Change the Text Placeholders on the Cover 
Every Multi-Touch book template supplied by Apple has a book cover 
with three text placeholders on it (see Make Placeholders for more 
about those). One of those placeholders contains the book’s title, which 
is, by default, “Book Title”. The others can be used for a subtitle or the 
author’s name. To change the text in any of the placeholders, select it 
and type your replacement. 

The paragraph styles of these placeholders can tell you 
their intended purposes: In the Craft template, the small text at 
the top of the cover has the paragraph style Edition; the text at the 
bottom has Author. You can see an assigned style in the Styles drawer 
(if it isn’t visible, choose View > Show Styles Drawer [Command-
Shift-T]) when you place your insertion point in a placeholder. 

The placeholder for Book Title is rather special: whatever text you type 
to replace the default title in the placeholder on the cover also appears 
as the label beside the book cover item in the Book sidebar. 

Tip: You can also change the text in the book title placeholder by 
editing the label of the book cover item in the Book sidebar: click the 
label to make it editable, make your changes, and then press Enter. 
The label changes, and so does the title on the book’s cover. 

Note: The book’s title on the cover is an example of an iBooks Author 
feature known as updating text (see Use Updating Text). 

You can modify the typeface and type style of the text in any of the 
placeholders either by using the commands available on the Format 
menu, by using the formatting tools available on the Format bar above 
the main work area when text is selected (if it’s not present, choose 
View > Show Format Bar [Command-Shift-R]), or by choosing a new 
style from the Styles drawer. 
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A Family Resemblance
 

iBooks Author uses text and object formatting tools and menu 
commands much like those in Pages, Keynote, and Numbers. 
If you are familiar with any of these programs, you already know 
how many of iBooks Author’s text and graphic manipulation tools 
and commands work. 

In this book, I focus on the tools and commands that are unique 
to iBooks Author and assume that you know how to do things like 
change a typeface or a paragraph’s justification. If not, consult the 
iBooks Author Help (in iBooks Author, choose Help > iBooks Author 
Help); the topics Format Text (under Add and Format Text) and 
Object Basics (under Graphics, Media, and Other Objects) explain 
how these tools and commands work. 

Change the Image Placeholders on the Cover 
In addition to the text, you can change the background art, line art, 
and any other graphics on the cover. For example, Figure 19 shows 
the unmodified book cover from the Craft template and the same 
cover after I edited the text placeholders and replaced the cover art. 

Figure 19: A cover before and after editing. 

Here’s how I replaced the picture shown on the cover of the book and 
the background image that appears behind the text and cover picture. 
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Note: Not all templates provide both a placeholder foreground image 
and a background image. For example, the Contemporary template 
has no foreground placeholder image. 

Is an image a placeholder? To find out, hover your pointer over 
it. If it’s an image placeholder, you’ll see a Help tag that says, “This 
image is a placeholder. Drag a new media file here to replace it.” 

The cover’s foreground picture was the simplest to change: if a 
template has a cover picture, it comes as an image placeholder, so, to 
replace the placeholder picture, you drag a picture of your own over 
the placeholder and drop it. You can drag a picture from a folder in the 
Finder, or you can use the Media browser to get a picture from your 
iPhoto or Aperture library (to bring up the Media browser, click Media 
in the iBooks Author Toolbar, or choose View > Show Media Browser). 

I replaced the dragonfly picture on the Craft template cover with my 
own picture of the moon above a palm tree, and then I adjusted the 
picture’s mask and magnification to show just the part of the picture 
I wanted visible (Figure 20). 

Figure 20: Adjusting the mask and magnification of an image. 
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To adjust the mask and magnification of a placeholder image, click 
the picture and then, in the popover that appears, do either or both 
of the following: 

•	 Drag the slider to adjust the magnification. 

•	 Click Edit Mask, and then drag the image to position it within the 
placeholder’s frame 

If you drag without clicking Edit Mask, you can drag the placeholder 
itself rather than the image within it; you can also use the placeholder’s 
size handles to change its size. 

Note: The replacement image that you drop becomes a placeholder 
as well. You can replace it by dropping another image file on it. 

Changing the background image in the Craft template was only slightly 
more difficult. Instead of being a placeholder image, the background 
in the Craft template is nothing more than an ordinary image that is 
layered behind the other items shown on the book cover; replacing it 
meant that I had to remove it and put another picture in its place. Here 
are the steps I followed, generalized: 

1. Click somewhere on the background image to select it, making 
sure not to click an item that is on top of the background image 
(choose View > Show Layout Boundaries [Command-Shift-L] 
to see the edges of text placeholders). You know you have clicked 
the right object if you see the square image control handles at each 
corner of the cover background image (you may not see all of the 
handles if the image extends beyond the borders of the window). 

2. Press Delete. This removes the image, and it gives you a white 
background. 

3. Drag a picture from a folder or from the Media browser and drop 
it on the cover (but not on the placeholder image—you don’t want 
to replace that image). The picture appears, selected, on top of the 
other items on the cover. 

4. If the picture has a frame around it, use the Graphic Inspector to set 
the picture’s Stroke to None (Figure 21). Choose View > Inspector 
(Command-Option-I) if the Inspector is not visible. 
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Figure 21: The Graphic Inspector, one of the ten Inspectors 
available in the Inspector window, is selected at the top of the 
window. 

5. Use the control handles at the edge of the picture to adjust its size, 
and drag the picture so that it completely overlaps the cover. 

6. Choose Arrange > Send to Back (Command-Shift-B). 

Tip: You can open more than one Inspector at once: choose View > 
New Inspector to open a new Inspector, or Option-click an icon at 
the top of an already-open Inspector to open the Inspector that the 
clicked icon represents. 
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Change the Intro Media 
Every template provides an Intro Media element as the first thing 
the reader sees after the cover when the book opens for the first time. 
It occupies the entire screen. You can use the Intro Media to display 
a picture (like a traditional book’s frontispiece), or to play a video file 
that introduces the book. To add a graphic or video file, drop it on the 
Intro Media page from the Finder or from the Media Browser. 

You can use most standard image formats for the Intro Media: TIFF, 
JPEG, PNG, and even Photoshop files work. When you drop an image 
file on the Intro Media page, you get the same image manipulation 
popover that I described in Change the Book Cover (see Figure 20, 
a few pages earlier). Use this popover to adjust the magnification and 
positioning of the visible portion of the image on the Intro Media page. 

Although previous versions of iBooks Author were somewhat picky 
about what kinds of media files you could use in a book, including 
for the Intro Media page, iBooks Author 2 can handle any media type 
supported by QuickTime. When you drop a video file on the Intro 
Media page, iBooks Author optimizes it for playback; this may take 
a minute or so to complete, depending on the size of the video. 

A video initially appears centered over a black background on the 
Intro Media page with a big play button centered on it (Figure 22). 

Figure 22: An Intro Media movie with a friendly Play button. 
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You can click the big play button to see a preview, but note that this 
button appears only within iBooks Author. Instead, readers of the 
book have the standard iPad video playback controls. The Intro Media 
video begins playing the moment the reader opens that page. 

Keep your intro short: Use a short video file (no more than a 
minute or two) for your Intro Media. This feature is meant to be used 
as a simple introduction and not anything more substantive. Short 
and simple is best strategy here. 

To adjust the size of the video and its position against the background, 
use the Metrics Inspector (Figure 23). However, you probably won’t 
have to: iBooks Author adjusts the size and position automatically to 
fill the page and center the video within it. 

Figure 23: The Metrics Inspector handles resizing and positioning 
of items on the page. 
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What about audio? In previous versions of iBooks Author, you 
could have audio-only Intro Media. However, it was an unsatisfying 
experience for the reader: The audio had no controls, so the reader 
saw a black page while the audio played and had no way to pause or 
rewind the audio. 

If you must have an audio introduction, make it into a video file with 
an image that displays while the audio plays (you can easily make such 
a movie in iMovie, for example). That way, your reader has something 
to look at instead of a completely black iPad screen. 

Note: If you don’t put anything on the Intro Media page, the page 
doesn’t appear in the final Multi-Touch book that you produce. 

Change the Table of Contents 
For Multi-Touch books based on a Landscape with Portrait template, 
you have not one Table of Contents but two of them to customize: the 
one that appears when the user’s iPad is held in landscape orientation 
and the one that appears in portrait orientation. (As you might expect, 
for Portrait Only books you only customize a single Table of Contents.) 

When customizing a Landscape with Portrait template’s Table of 
Contents, you can use the Orientation control in the iBooks 
Author Toolbar to view your book in each orientation. I talk more 
about designing your book for these two orientations in Flip It for a 
Different View, but here’s what you need know about how the Table 
of Contents appears in each view: 

•	 Landscape Table of Contents: In this view, the reader sees 
the contents list for each chapter on a separate page (Figure 24). 
By default, each chapter’s sections are listed on its contents page, 
and thumbnails of the chapter’s pages appear across the bottom 
of the contents page. In a published book, your readers can tap a 
thumbnail to go to the corresponding page in the chapter, although 
in iBooks Author those thumbnails are represented by faint gray 
translucent rectangles (almost invisible near the bottom of the left-
hand image in Figure 24) and have no navigational capabilities. 
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Figure 24: Two views of a Table of Contents, with landscape 
orientation on the left and alternate portrait orientation on the right. 

The different chapters’ contents pages in the landscape Table of 
Contents are reached by clicking the white dots at the very bottom 
of the contents page; the number of dots indicates the number 
of chapters (you won’t see any dots if you have only one chapter). 
Unlike the page thumbnails, the white dots do work in iBooks 
Author. 

•	 Alternate Portrait Table of Contents: When a reader views 
your book in portrait orientation, the Table of Contents appears 
as a scrollable list below a header containing the book’s title. Each 
chapter is listed, and a disclosure arrow to the right of a chapter 
name expands the list to show that chapter’s sections. None of 
Apple’s current templates provide more artwork on the page 
than a background for the book title banner, so it’s quite easy 
to customize the portrait layout: there’s not much to customize! 

In neither view can you edit the text that displays the chapter’s 
name, its number, or its sections; that text is automatically generated 
based upon the chapters and sections currently in the book. You can, 
however, change the appearance of the text in the Table of Contents. 
You can also change the background art in either view. 

Tip: You can show or hide the page numbers for sections and other 
headings that appear in the Table of Contents with the Show Page 
Numbers in TOC checkbox in the Document Inspector’s TOC pane. 
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What about customizing a Portrait Only Table of Contents? 
The sole Table of Contents available in a Portrait Only template offers 
the same features as a Landscape Table of Contents. The techniques 
for customizing the Portrait Only Table of Contents are the same as 
for the Landscape Table of Contents, presented just ahead. 

Change a Landscape Table of Contents 
To change the appearance of the landscape Table of Contents’ chapter 
name and chapter number text items, click the chapter name or 
number item. Width control handles appear at either end of the item. 
Now you can do any or all of the following: 

•	 Change the look of the text: Use the Font and Text commands 
on the Format menu or the controls on the Format bar. 

• Adjust the item’s width: Drag the width controls. 

•	 Reposition the item on the page: Click within the boundaries 
of the item and drag. 

The text box in the landscape Table of Contents that contains the list 
of sections within the chapter is just as easy to customize: 

•	 Adjust the section list’s size and shape: Click within the text 
box to select it, and then drag any of its control handles. 

•	 Reposition the section list: Click within the text box to select 
it, and then drag. 

•	 Change the appearance of the section titles: Double-click 
any section title shown to select all of them, and then use any of the 
text formatting tools and commands from the Format menu or the 
Format bar. 

To replace the background, you may be able to follow the same 
procedure I described for changing the background on the book cover 
in Change the Book Cover, earlier in this chapter. I say may because 
different templates can implement their backgrounds in other ways: 

•	 Check for a locked background: A template might have locked 
the background image so that you can’t inadvertently drag or delete 
it. You can tell a locked item by very faint X symbols at its 
corners and sides where its control handles would normally appear. 
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To unlock a locked item, click to select it and then choose Arrange > 
Unlock (Command-Option-L). Once it is unlocked, you can delete it. 

•	 Check for a placeholder background: Templates that have 
placeholder backgrounds are the easiest to change, since you don’t 
need to do anything more than drop a new image on the placeholder 
to replace the current picture. The Contemporary template, for 
example, uses a background placeholder on its landscape Table of 
Contents. 

Don’t change the foreground placeholder from within the 
table of contents! Some templates, such as the Craft template that 
I use to illustrate this chapter, include a foreground placeholder 
image on the landscape Table of Contents (the dragonfly image in the 
unaltered Craft template; the view of the ocean in my modified Table 
of Contents shown in Figure 24, slightly earlier). Don’t mess with it: 
that placeholder links to a placeholder image on the first page of each 
chapter. iBooks Author doesn’t give you the ability to remove it from 
the Table of Contents, and if you replace the placeholder image in the 
Table of Contents it won’t show the image that you use on the first 
page of the corresponding chapter. See Make Placeholders. 

Change an Alternate Portrait Table of Contents 
The portrait Table of Contents supplied with a Landscape with Portrait 
template has very few items that you can change. Each of the nine 
templates that Apple provides in iBooks Author 2 have portrait tables 
of contents that contain a text item displaying the book’s title; in a few 
templates this text item appears above a background image. None are 
more complicated than that. 

If the portrait Table of Contents in a template has a background 
image, you can change it using the same procedure that I describe 
for changing a book cover’s background in Change the Book Cover. 

Just as you can with the book title on a book’s cover, you can select 
and edit the text item that displays the book’s title on the portrait Table 
of Contents. Furthermore, just as with the title on the cover, changing 
the title text on the Table of Contents layout changes the actual title of 
the book. You also can adjust the title’s typeface, size, and position as 
you can the text on the book’s cover. 
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Additionally on a portrait Table of Contents, you can adjust the height 
of the banner that contains the book title and background: 

1. Position your pointer on the boundary between the banner and the 
contents list. Your pointer changes to a horizontal drag pointer and 
a pair of arrows appears (Figure 25) on the separator line. 

2. Drag up or down to adjust the banner’s height. 

Figure 25: You can drag the separator in a portrait Table of 
Contents to adjust the height of the banner. 

You cannot change the appearance of the items listed in a portrait 
Table of Contents: the typeface and layout of the list is hard-wired. 

Modify the Layouts 
Every template that Apple supplies in iBooks Author has a variety 
of layouts stashed in it that you can use and modify. Each chapter, 
section, and page in your book is based upon a layout stored in 
the template. These layouts dictate where text appears, where page 
numbers and titles appear, where various graphic elements appear, 
and what they all look like. 

Think about the layouts as being the clothes that the chapters, sections, 
and pages in a template wear. Just as the same suit can be appropriate 
for wearing to the office or to the theater, the same layout can be used 
for very different kinds of content. For example, the layouts in the 
Classic template, which in the Template Chooser looks like an art 
history book, could just as easily be used for a botany textbook as 
could the Basic template, which resembles a botany textbook—just 
change the artwork in its layouts. 
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Some layouts are special: A few templates do have specialized 
layouts suitable for specific types of content: for example, the 
Cookbook template offers a Section Recipe layout, and the Photo Book 
template has layouts designed for photos. Such specialized layouts 
are a convenience, but don’t let the absence of one from a template 
lead you not to choose that template if it otherwise suits your need: 
you can make similar specialized layouts in any template with the 
capabilities that iBooks Author provides. 

When you change the appearance and arrangement of a layout, all your 
book’s pages that use the changed layout take on the new look. You can 
also create new layouts for chapter openers, section openers, and text 
pages and save them in your template. 

To create new layouts, or to change existing ones, you first must 
be able to see and select the layouts. iBooks Author has a command 
for that: View > Show Layouts (or use the View control on the Toolbar 
to reveal the layouts). When you show layouts, they appear in the left 
sidebar above the Book sidebar (Figure 26). 

Figure 26: The Layouts list appears above the Book sidebar when 
you choose View > Show Layouts. 
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Note: When you use a Landscape with Portrait template, the layouts 
you see in the sidebar depend on the orientation you are viewing. 

To create a new layout, you must first show the Layouts list in the 
sidebar and then click a layout to select it. This makes the Insert > 
Layouts command available, and from it you can choose to insert a 
new Chapter layout, Section layout, or Page layout into the Layouts 
list. All new layouts come with the name Untitled master; I suggest 
that you immediately rename a new layout when you create it, giving 
it a name that identifies its purpose, such as Answer Key Chapter. 

To rename any layout, select the layout in the Layouts list, click within 
its name to get a text cursor, and then edit as you would any text. 

Easier to clone than to create: New layouts that you insert in 
the Layouts list are blank, containing none of the graphics and type 
settings from the template you chose. In most cases, it is much more 
convenient to duplicate an existing layout from the template, change 
its name, and then customize the duplicate. To duplicate a layout, 
select it in the Layouts list and choose Edit > Duplicate. 

Tip: The headings above each group of layouts in the sidebar are 
editable, and iBooks Author uses them for title prefixes. For example, 
if you change the Chapter heading in the Layouts sidebar to “Learning 
Module,” the Chapter Number placeholder on the first page of a 
chapter uses that as the chapter number prefix: “Chapter 1” becomes 
“Learning Module 1” and so on. 

Tip: Many of the techniques I described for modifying text and image 
objects in the previous section, Customize the Opening, come into 
play when you modify a template’s layouts as well, so if you haven’t 
read that section, you might want to cast your eye back a few pages. 

In the pages ahead, I explore the details of how to Change a Main 
Chapter Layout, Change a Section Layout, and Change a Text Page 
Layout. With those topics covered, I answer a question that you may 
begin wondering about as you learn about editing the layouts—how to 
Make Placeholders. Finally, I describe how to Save a Template if you 
want to use it within a different iBooks Author project. But first, some 
useful terminology. 

65 



        
       

     
         

          
          

      
         

          
         

            
        

           
         

        
      

          
          

           
        

        
          

          
           

            
        

   
            

       

          
           

            
              

           
            

Tip: As you work through the following sections, remember that you 
can add new chapters, sections, and pages with the Insert > Pages 
command. A newly inserted element appears just below the selected 
element. You can delete an element by selecting it in the sidebar and 
pressing Delete. To move a chapter or section (though not a page), 
you can drag it in the sidebar. So feel free to experiment! 

Know Your Chapter Layout Terms and Views 
The chapter layouts for the landscape layout of Landscape with 
Portrait templates and the chapter layouts provided by Portrait Only 
templates offer similar features. I call these layouts main chapter 
layouts, as opposed to the alternate portrait layouts that you also get 
in Landscape with Portrait templates (see Choose between Portrait 
and Landscape Templates). 

Tip: To view a main chapter layout if you are working in a Portrait 
Only template, just select it in the Layouts sidebar. To view a main 
chapter layout in a Landscape with Portrait template, first switch to 
Landscape view and then select the layout from the Layouts sidebar. 

In Apple’s templates, each main chapter layout consists of two pages 
or spreads: an opening (or head) spread and a following text (or body) 
spread. These are presented horizontally so if you can’t locate the 
second spread, scroll to the right, not down. 

In Landscape with Portrait templates, the alternate portrait chapter 
layout—which you see in Portrait view, like the alternate portrait Table 
of Contents I describe in Change the Table of Contents—comprises 
a large heading area followed by a single, possibly blank, expandable 
text page area. In the following sections, I deal with changing a main 
chapter layout and an alternate portrait chapter layout separately. 

Change a Main Chapter Layout 
The head spread of a main chapter layout typically contains some or 
all the labeled items shown in Figure 27: 

•	 Chapter title (A): This text object is hard-wired to display the 
chapter’s title when a new chapter is created (iBooks Author’s Help 
calls this an updating text field). You don’t change its wording in 
the layout, but when you change its text in a chapter that uses the 
layout, whatever you type there changes the name in the sidebar 
and in the Table of Contents. Double-click the object to see a 

66 



          
            

            
    

        
          
           
           

           
         

          
          

              
            

         

       
         

       
 

popover with which you can make this object display the book’s title 
instead. You can also, of course, move this object around, change its 
appearance, add your own text to either side of the hard-wired text, 
and even remove the object. 

•	 Chapter number (B): This item contains an updating text field 
that displays the chapter’s number in chapters you create from 
this layout. Double-click the text to see a popover, from which you 
can select whether the field displays just the chapter number, the 
chapter number prefaced by the word “Chapter”, or just the word 
“Chapter”. (In iBooks Author 2.0, this popover is misleadingly 
labeled Section Number, even though in this context it controls the 
chapter number field.) You can modify the appearance of its text, 
you can add your own text to either side of the updating text field, 
and you can remove this object. You can override the settings you 
make here in the individual chapters of your book. 

Figure 27: Modifying a main chapter layout from the Craft template 
with the following parts: chapter title (A), chapter number (B), 
background (C), main image (D), other placeholder images (E), and 
introduction (F). 
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•	 Background (C): This graphic object, when present, is on a layer 
behind all the other objects on the layout. Just as with Tables of 
Contents and book covers (see Change the Book Cover and Change 
the Table of Contents), some templates use a placeholder image 
and others, such as the Craft template in Figure 27 (above), use 
a locked image: 

‣	 If the layout uses a placeholder, you can change the background 
on a chapter by chapter basis by dropping a different image on 
it in each chapter. 

‣	 If, like the Craft template, it uses a locked background, you 
can change it in the layout by selecting it, unlocking it (choose 
Arrange > Unlock [Command-Option-L]), deleting it, and 
placing a new image behind the others. You can even make 
it a placeholder image (see Make Placeholders) in the layout. 

•	 Main image (D): Only some templates have a main image object. 
To find out if yours has one, open the Layout Inspector to its Layout 
pane. On the main chapter layout, select an image. If the Tag field 
in the Layout pane says main image, then the main image object is 
selected (see The Helpful Layout Inspector, a page or so ahead). 

The main image object is a placeholder: you don’t change it in the 
layout, but whatever you drop on it in a chapter head replaces it for 
that chapter. This image also automatically appears in the chapter’s 
entry in landscape Table of Contents. You can move this placeholder 
in the layout and you can resize it—but don’t delete it. iBooks 
Author does not allow you to remove the corresponding placeholder 
main image object from the Table of Contents, so if you remove it 
from the chapter layout you’ll have to provide an image manually 
for each chapter displayed in the Table of Contents. 

•	 Other placeholder images (E): These are added for decorative 
purposes, and you can resize, move, or delete them at will. 

•	 Introduction (F): You replace the placeholder text in this object 
with introductory text in each chapter. You can move this object 
around, adjust its size and appearance, and delete it. It does not 
participate in the text flow of a chapter (see Format and Flow), 
so it is constrained by its size. Note, by the way, that the object 
in Figure 27 (above), which comes from the Craft template, has 
a decorative frame and background; you can adjust it using the 
Graphic Inspector. 

68 



               
             

            
              

                

             
           

          
           

           
            
    

         
        

   

              
          

              
        

        
          

      

          
        

         

The body spread in a main chapter layout has a body text object, and it 
is the default layout for the text pages in your chapter that immediately 
follow the chapter’s opening page. The body text object is designed so 
that text flows from one column to another; if you add a second text 
page, the text will flow from the first page to the body text object on the 
second, and so on (see Format and Flow). 

You can replace the background of the body spread, and, if it contains 
placeholder text, you can change the style, font, size, and other 
characteristics of its body text object (double-click the placeholder text 
and use the Format bar, Styles drawer, and various Inspectors as 
desired). This spread typically also contains a page number text object 
(it’s an updating text field); you can adjust this object’s size, location, 
and appearance as you wish. 

Tip: If the body spread in a main chapter layout contains no 
placeholder text, you can add some to the layout and specify its text 
characteristics; see Make Placeholders. 

When you make changes to either of the spreads of a chapter layout, a 
red Apply Changes button appears in the Layouts sidebar. 
Click it to apply the changes you have made to both the layout and to 
all the pages in your book that use it. 

Tip: You can drag a different chapter layout from the Layouts sidebar 
and drop it on a chapter in the Book sidebar to apply that layout to 
that chapter, making it easy to try out different looks for a chapter. 

Tip: When thumbnails are showing in the Book sidebar, you can also 
click the Change Chapter Layout arrow that appears when your 
pointer is over a chapter thumbnail to choose a different chapter 
layout. 
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The Helpful Layout Inspector
 

The Layout Inspector is a useful tool when you’re noodling around 
in a layout (Figure 28). It has two panes: a Layout pane and a 
Numbering pane: 

✦	 Layout pane: With the Layout pane, you can adjust the size 
and number of columns of any text object in a layout, specify 
how placeholders behave (see Make Placeholders), specify for 
each object in a layout whether it can be edited on the pages in 
your book that use the layout, and see if any of the placeholders 
have names. This last can help you figure out what some of 
the items in the layout are for (click an object and look at the 
Inspector’s Tag field). 

✦ Numbering pane: You use the Numbering pane to manage how 
automatic page, section, and chapter numbers appear. 

Figure 28: The two faces of the Layout Inspector. 
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Change an Alternate Portrait Chapter Layout 
The alternate portrait chapter layout available in Landscape with 
Portrait templates typically contains some or all the labeled items 
shown in Figure 29. The chapter title (A), chapter number (B), main 
image (C), introduction (D), and background of the top (or banner) 
area, function identically to those in the main chapter layouts, as 
described just previously. However, this layout handles the body 
text object differently, as does the way it displays images. 

Figure 29: A portrait chapter layout, showing these parts: chapter 
title (A), chapter number (B), main image (C), introduction (D), and 
thumbnail track (E). 

Some alternate portrait chapter layouts include a body text object 
with placeholder text below the header. When that is present, you 
can’t adjust its dimensions or the number of columns, but you can 
adjust its text properties (such as the typeface, size, and so on). 

In other alternate portrait chapter layouts, instead of a body text 
object, you get—nothing. If the corresponding spread in the landscape 
orientation has text, iBooks Author handles the portrait view text 
object’s dimensions automatically, and applies whatever body text 
formats you specified in the landscape layout’s body spread. 
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In either case, when you view a Landscape with Portrait book in 
portrait orientation, the text for a chapter or section appears in a 
single page below its banner, and the body text object on that page, 
along with the page itself, grows to accommodate the amount of 
text it contains, much like a Web page does. 

When readers view your book in portrait orientation, floating and 
anchored graphic objects that you place in the text in landscape view 
appear as thumbnails in portrait view (I discuss floating, anchored, 
and inline items in Add Illustrations and Figures). Readers have to 
click the thumbnails to see these items at full size. You can use the 
Layout Inspector when in the alternate portrait chapter layout to hide 
the thumbnail track of the chapter layout (deselect Show Thumbnail 
Track), in which case these items don’t appear at all in the alternate 
portrait view. 

Note: To appear in the thumbnail track, floating or anchored graphics 
must have either a title or a caption or be enabled to view as full-
screen (described in Lay Them Out like Widgets). Inline items and 
widgets always appear within the text in both landscape and portrait 
orientations. 

The Virtues of the Preface Layout
 

The Apple templates each have two standard chapter layouts: one 
named Chapter and one named Preface. I’ve concentrated on the 
Chapter layout in this section, but the Preface layout has its virtues: 
in every template it’s much less cluttered with items than the Chapter 
layout. Just because this layout is called Preface doesn’t mean that 
it’s only good for book prefaces. 

If you desire a sparer, less fussy opening for your book’s chapters, 
consider duplicating the Preface layout and customizing it for all your 
book’s chapters. 

Change a Section Layout 
Sections allow you to divide the content of your book’s chapters into 
smaller units. For example, suppose your book is Lives of the Great 
Poets, and it has chapters devoted to the poets of different historical 
periods; your chapter on “English Romantic Poets” might then have 
individual sections that discuss Shelley, Wordsworth, Coleridge, and 
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Byron, with the opening pages of the chapter devoted to describing 
the historical period in which they lived. 

iBooks Author can easily support a book structured like that: as 
you’ve seen in Know Your Chapter Layout Terms and Views, chapters 
in a book begin with a head page and then, optionally, one or more 
body text pages; in the alternate portrait view of a Landscape with 
Portrait book, they begin with a banner and then, optionally, one 
expandable body page. Following the chapter’s body pages, you can 
place one or more sections (usually more, because a chapter with only 
one section would seem odd). 

Sections in chapters always appear at the end of chapters: 
A chapter doesn’t have to contain sections, but if it does, the sections 
always follow the body pages, if any, of the chapter; if a chapter has 
no body pages, the sections follow the chapter’s head page or banner. 

Note that “end” does not imply “an addendum following the chapter’s 
main contents.” In many cases, most of a chapter’s contents will 
appear within the chapter’s sections and not in the body pages 
following the chapter’s head page. In such cases, the end is much 
larger than the head (as is the case, I fear, for many of us). 

Also note that sections do not have to be part of a chapter: you can 
place sections outside of chapters, standing on their own at the same 
level as the book’s chapters. For example, Figure 30 shows the 
outline for a book in which a stand-alone section follows the second 
chapter. 

Figure 30: A book with one section inside a chapter and one section 
standing on its own. 
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Tip: You can switch what’s displayed in the Book sidebar between 
Page Thumbnails and Book Outline (shown in Figure 30, above) 
with either the View menu or the View tool on the Toolbar. 

iBooks Author provides several standard section layouts that you 
may want to place on their own outside of any chapters; for example, 
the Copyright and Foreword section layouts. Figure 31 shows the 
standard section layouts provided by iBooks Author’s Classic template; 
different templates may provide a somewhat different assortment. 

Figure 31: The section spread layouts in a template (this one is 
from the Classic template). 

Here are descriptions of typical section spread layouts in the Apple 
templates: 

•	 Section: Most book templates include one or more section layouts 
with names that begin with Section: Section, Section Text, Section 1 
Column, and so on. These layouts are designed to hold the bulk of 
your content and you’ll typically use one or two of them for most of 
the sections in your book. 
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Some Section layouts have a section image placeholder (sometimes
 
accompanied by a text placeholder for a caption). All of them have a
 
body text placeholder that flows into subsequent body pages in the
 
section (see Format and Flow). They also tend to have section title
 
and section number placeholders with updating text items similar
 
to those in the chapter title and chapter number placeholders
 
(discussed in Change Main a Chapter Layout). Section layouts
 
typically include a page number placeholder with an updating text
 
item that supplies the number.
 

Sometimes a Section layout has an objectives text placeholder.
 
This is where you would put the learning objectives for that section,
 
or a list of the main points covered in the section; the objectives
 
placeholder’s default format is an automatically numbered text
 
list with a heading. Figure 32 depicts the Section layout from the
 
Editorial template.
 

Figure 32: A typical Section layout; this one is from the Editorial 
template (it must have been a very inflammatory editorial). 

Tip: If your section needs neither an objectives item nor a picture on 
its opening page, you can usually find a layout that is text-only, such 
as the Section Text layout shown in Figure 31, just a little earlier. 
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•	 Copyright: Use this section layout for the copyright page(s) of 
your book. It contains a section title text object with an updating 
text item that controls the section’s name in the Table of Contents 
just like the other section and chapter layouts do. 

The default name for a newly created section is “Untitled,” although 
you will probably change it to something like “Copyright” if you 
use this layout for its intended purpose. It has no section number 
placeholder because copyright pages are seldom numbered. The 
body text placeholder is typically bottom-justified in the Copyright 
layout for each template: as you add information, the text grows 
toward the top of the page. If you supply a great deal of copyright 
information, this text object flows its contents into the body text 
pages of the section (see Format and Flow). The updating text item 
in the page number placeholder is usually set to show lowercase 
Roman numerals, though you can change that in the Numbering 
pane of the Layout Inspector (read The Helpful Layout Inspector). 

•	 Dedication: If your book has a dedication, you can use this layout. 
It has the typical section title placeholder that links to the Table 
of Contents, a page number placeholder set up to show numbers 
in Roman numerals, and a body text item set for italics (though 
you can change this). It has no section number placeholder. Most 
dedications are short, but if you have a large number of dedicatees, 
the text of this placeholder flows into subsequent text pages. 

•	 Foreword: Use this for books with forewords. Like the other 
section layouts designed for a book’s front matter, the section 
title links to the Table of Contents, the page number is set to show 
Roman numerals, and it lacks a section number placeholder. Some 
Foreword section layouts include an italicized quotation block for 
an epigraph along with an attribution block followed by normal 
body text in the body text placeholder (Figure 33), though you can 
delete or modify the appearance of any of these blocks if you want. 
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Figure 33: The Foreword layout from the Craft template, including 
placeholder text blocks for both an epigraph and its attribution. 

Tip: As with chapters, when thumbnails are showing in the Book 
sidebar, you can click the Change Section Layout arrow that 
appears when your pointer is over a section thumbnail to choose 
a different section layout. 

Each landscape view section layout has a matching alternate portrait 
view section layout in a Landscape with Portrait template. The 
alternate portrait view layouts for sections are similar to the alternate 
portrait view chapter layouts described in Change an Alternate Portrait 
Chapter Layout: they each have a resizable header area that has text 
and image placeholders, and a scrolling page below that contains an 
optional thumbnail track. And, like some alternate portrait chapter 
layouts, you can modify the text format of the scrolling page in 
alternate portrait section layouts. 

Generally, you should duplicate any layout you want to modify so you 
can revert to the original if necessary. You use the same techniques 
for changing the appearance and objects that you use when modifying 
chapter layouts (see Change a Main Chapter Layout), so I won’t 
describe them here. 
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Tip: You can make modified versions of the special purpose section 
layouts for other standard book parts. For example, the Dedication 
layout can easily be used for Acknowledgements, and the Foreword 
is equally useful for a Conclusions section. 

Importing Tips
 

As you learned back in Import Text, you can import Word or Pages 
documents as chapters or sections. What’s more, if the document 
you import has section breaks in it, the import process uses those 
breaks: if you import the document into a chapter layout, iBooks 
Author creates a new chapter at each break; if you import into a 
section layout, iBooks Author creates a new section at each break. 

This has some drawbacks. When you import into a chapter layout, 
you end up with a series of chapters that have no internal sections. 
If you want those chapters to have internal sections, you have to 
create those sections in iBooks Author and then cut and paste from 
the chapter’s body text into each section. 

Similarly, when you import into a section layout, the text is split 
up into sections within the chapter currently selected in the iBooks 
Author sidebar, skipping the body text of the chapter opening. If, 
however, you want the first section that you imported to be the body 
text of the chapter opening, you have to cut its text from the first 
section, paste it into the chapter’s body text, and then delete the 
first (now empty) section. 

Or, instead, you can carve your document up ahead of time: 

1. In your word processor, cut the first section, create a new 
document, paste the text, and save the new document as a 
separate document. For a typical chapter, you end up with two 
documents: a chapter opening document and a chapter section 
document, with the second document containing all but the first 
section of the chapter. 

2. Import the chapter opening document into a chapter layout. 

3. Import the chapter sections document into a section layout for 
that chapter. 

Sure, it sounds tedious, but you can carve up an entire book-length 
manuscript in this fashion in less than an hour. 
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Change a Text Page Layout 
Each of the Apple templates comes stocked with individual page 
layouts, usually offering a main text placeholder with varying numbers 
of columns, and sometimes offering sidebars or placeholders for 
images in addition to a main text placeholder. You use the page layouts 
either to change the layout of an existing page in your book or to add 
blank pages with a specific layout following the existing pages in a 
chapter or section. 

Note: Remember that in a Landscape with Portrait layout, page 
layouts only can be applied to the landscape view of your book; in 
the alternate portrait view, the body of a chapter or section is one 
long ever-expanding page. 

To replace the layout of an existing page with another layout, do the 
following: 

1. Select the page in the Book sidebar (if necessary, choose View > 
Page Thumbnails first). 

2. Click the Change Page Layout arrow that appears to the right 
when your pointer is over the thumbnail. 

3. On the Change Page Layout menu that appears, choose the layout 
you want to apply to the page (Figure 34). The text reflows to 
accommodate the new layout. Note that if you apply a blank page 
layout to an existing page that contains text, the text flow jumps 
over the blank page to the next available text body page in the 
chapter or section. 
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Figure 34: Applying a new layout to an existing text page. 

Adding a page to a chapter or section is even easier: click the Add 
Pages tool on the Toolbar, or choose Insert > Pages, and choose a 
page layout from the Pages submenu. A page with the layout you have 
chosen appears at the end of the currently selected chapter or section. 

You can create new page layouts in the Layouts sidebar or modify 
existing ones as you can with section and chapter layouts. As with 
chapter or section layouts, I suggest you duplicate any layouts you 
want to change and modify the duplicates; the duplicates, which you 
can—and should—rename, appear on the Pages and the Change Page 
Layout submenus when you create them. 

The page layouts are mostly about the body text, so when you’re 
modifying a page layout, most of your work will involve changing 
the main text placeholder’s typeface, default justification, and other 
characteristics, though, if a layout has additional text placeholders, 
such as one for a sidebar, you may want to change that, too. 
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Here’s a general guide to changing a text placeholder in a layout 
(or, for that matter, on any given page in your book): 

•	 Default justification, tab stops, list characteristics, line 
spacing, and paragraph indents: Select a text placeholder in 
a page layout and use the various controls in the Text Inspector. 

•	 Border and background fill of the body text: Select a text 
placeholder and use the controls in the Graphic Inspector. 

•	 Typeface, size, color, and style: Select the placeholder text 
within a text placeholder and use the controls on the Format bar 
or the commands on the Format > Text submenu. 

•	 Number of columns, column widths, and gutters: Select 
a text placeholder and use the controls in the Layout Inspector. 

Tip: Except for a Blank page layout, which has none, the body 
page layouts all have a body text placeholder object through which 
the text of the chapter or section flows. You can, however, have more 
than one body text placeholder object through which text can flow if 
your page design requires it. For details, read Format and Flow. 

Make Placeholders 
If you’ve been reading along in this chapter, you probably already have 
an idea of what placeholders are, since they appear as standard parts of 
the book parts and layouts I’ve been describing. Here’s a closer look at 
these very useful items. 

A placeholder in iBooks Author is either any contiguous run of text 
or a media element (including simple graphics) that you, as the book’s 
author, can replace in one fell swoop (this should particularly appeal 
to authors of falconry textbooks). For a media placeholder, you drop 
new media on the placeholder to replace it. For a text placeholder, you 
just click the text: the entire placeholder text is selected and the next 
thing you type—or paste—replaces that text. 

A placeholder has no distinct appearance to set it apart; the 
placeholder simply contains the replaceable text, graphic, or media. 
Think of placeholderishness, if you will, as an optional property 
that text or media can have within iBooks Author. When you publish 
a book, the placeholder property evaporates in the published book, 
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leaving the contents of the placeholder behind: placeholder text 
becomes text, and placeholder media becomes media. 

How you make a placeholder depends on where it is: placeholders 
can exist both in your layouts and on individual pages. Placeholders 
on a book page are best for marking individual items you know 
you want to change before you publish; in this case the placeholder 
is a reminder for the thing to be changed. A placeholder in a layout 
appears every time you use the layout, and is suitable for marking 
where a replacement is needed for each occurrence of the layout. 

Because iBooks Author doesn’t make it easy for you to spot a 
placeholder, you should use text or images that remind you of the 
sort of information that the placeholder represents (for example, 
AUTHOR’S NAME is good placeholder text for where you want to 
insert the author’s name). 

Make Placeholders on a Book Page 
Although placeholders really reveal their full splendor in layouts, 
they can have practical uses on individual pages. For example, you 
may want text placeholders on your book’s copyright page for the 
ISBN and Library of Congress Cataloging-in-Publication (CIP) 
information that you’ll replace just before you finish your book, 
or you may want a media placeholder for an image that has several 
alternatives upon which you haven’t decided yet (or for which you 
haven’t yet obtained rights). 

Here’s how you make a text placeholder: 

1. Select the text you want to make into a placeholder. 

Leave the final paragraph marker alone: If the selected 
text comprises one or more paragraphs, make sure not to include 
the final paragraph mark (you can see those with View > Show 
Invisibles [Command-Shift-I]); otherwise, when you replace 
the placeholder text, the last paragraph of your replacement 
becomes the opening text of the following paragraph because the 
concluding paragraph break in the placeholder text has vanished. 

2. Choose Format > Advanced > Define as Placeholder Text 
(Command-Option-Control-T). 
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As you might expect, you can turn a text placeholder back into 
ordinary text just as easily: 

1. Click the placeholder text to select it. 

2. Choose Format > Advanced > Define as Placeholder Text 
(Command-Option-Control-T) to uncheck the command and make 
the selected placeholder text ordinary. 

How to Edit Placeholder Text
 

If, as you work on your book, you realize that you need to edit 
placeholder text but still keep it as a placeholder, Choose Format > 
Advanced > Enable Placeholder Text Authoring. 

When this command is enabled, you can edit your text placeholders 
with impunity. Just remember to disable placeholder text authoring 
when you’re done fiddling so your text placeholders behave like 
placeholders again. 

Here’s how to make a media placeholder: 

1. From the Media browser in iBooks Author or from the Finder, 
drag the media you want to make into a placeholder and drop it 
on the page. 

2. Modify the media object as you wish, such as adding a border or 
a shadow. 

3. Choose Format > Advanced > Define as Media Placeholder 
(Command-Option-Control-I). 

Media placeholders remain placeholders until you publish your book, 
even when you replace their media with different media, or until you 
select a media placeholder object and choose the Format > Advanced > 
Define as Media Placeholder command again to deselect it. Unlike text 
placeholders, there is no command for enabling or disabling media 
placeholder editing. 

Make Placeholders in a Layout 
The procedures for making text and media into placeholders on 
a chapter, section, or page layout are identical to those for making 
placeholders on a book page. However, the helpful Layout Inspector 
has a few controls that appear when you edit objects on a layout. 
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Collected under the heading Layout Object, these controls affect 
placeholders and how they behave (Figure 35). 

Figure 35: The Layout Object section in the lower half of the Layout 
pane in the Layout Inspector has controls for placeholder behavior. 

Here’s what the Layout Object controls do: 

•	 Editable on Pages Using this Layout: Select this box if you 
want to be able to replace the placeholder contents on pages that 
use this layout. When this box is not checked, you can replace 
placeholder contents only when you edit the layout itself, but not 
when you edit pages that use that layout. In most cases, you want to 
have this box selected so you can replace the placeholders’ contents 
on the pages that use the layout. 

•	 Tag: This item is enabled only if Editable on Pages Using this 
Layout is checked. You can type a tag in this item in the Layout 
Inspector, or you can choose an existing tag from the pop-up menu. 
Individual tags can only appear once in each layout. 

Tags allow placeholders on different layouts within a book to share 
contents. The main image placeholder object, described in Change 
a Main Chapter Layout, is implemented with a tag that says main 

84 



            
         

           
          

            
       

           
      

            
          
             

           
         

 
              

              
     

     

           
    

 

             

        
           

             
          

          
        

   

        

          

            
             

image. That is how the chapter entries shown in Table of Contents 
in the Craft template, each of which has a placeholder with a main 
image tag, keep their images in sync with your book’s chapters (see 
Change a Landscape Table of Contents): whatever image you put 
in the main image placeholder in a chapter opening appears in the 
corresponding chapter entry in the Table of Contents. 

•	 Shared with Portrait Layout: As you have seen in Change an 
Alternate Portrait Chapter Layout and Change a Section Layout, 
not all items in a landscape layout appear in the alternate portrait 
layout in a Landscape with Portrait template. You can make a 
layout item you create in a landscape layout appear in the alternate 
portrait layout by checking this option. (This checkbox, by the way, 
is present in Portrait Only templates, but is always disabled.) 

Save a Template 
If you go to the trouble to customize a template, you might want to 
leverage your labors by saving the template so you can use it in another 
book. That’s easy enough to do: 

1. Choose File > Save as Template. 

2. Optionally, rename the template (if you don’t, the template has the 
same name as your book). 

3. Click Save. 

By default, templates are saved in the depths of the Library folder in 
your user account, at ~/Library/Application Support/iBooks Author/ 
Templates/My Templates/. Templates in that location appear in the 
Template Chooser. If you save them somewhere else, they don’t appear 
in the Template Chooser; the only reason to save them elsewhere is if 
you plan to archive them or give them to someone else. 

Note: Your user account’s Library folder is normally invisible in Lion 
and Mountain Lion. That’s why the steps below use the Go command 
to reveal the folder. 

To remove a custom template from your Template Chooser: 

1. In the Finder, choose Go > Go to a Folder (Command-Shift-G). 

2. In the dialog that appears, type (or copy and paste from this ebook) 
the full path from the Library folder in your user account to your My 
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Templates folder (~/Library/Application Support/iBooks Author/ 
Templates/My Templates/) and then click Go. 

3. Drag the template out of the folder to the Trash. 

If you want to add an iBooks Author template from some other source 
(say, from your publisher) to your Template Chooser, put it in the My 
Templates folder. 

Format and Flow
 

Back in How to Think about Your Book, I talked about how your book’s 
text forms the spine of your book. However, just as the human spine 
isn’t a single piece but comprises separate vertebrae, your book’s text 
spine comprises individual text flows that are contained within your 
book’s separate sections and chapters. 

Note: You can move these text-flow-containing sections and chapters 
around in your book and replace them, but you can’t rearrange or 
replace the pages that participate in a specific text-flow. Remember, 
the smallest units you can drag around in the Book sidebar are 
chapters or sections. 

Here are some of the things you can do with the text in your book: 

•	 You can insert new text blocks on a page so that the text flows 
through them (described just ahead). 

•	 You can break a text flow off. Read the details ahead, in Break a 
Text Flow. 

•	 You can create text blocks that are independent of a text flow. For 
details, see Create a Stand-alone Text Object or Shape, later in this 
chapter. 

•	 You can Format Text. This includes changing the typeface, style, 
size, and other visual characteristics of any text within your book, 
whether it is part of a text flow or not. 

•	 You can Use Updating Text—such as a section or page number—in 
a text flow or a stand-alone text object. 
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Note: The following discussions of modifying a text flow are 
irrelevant when it comes to the alternate portrait view of a Landscape 
with Portrait book. As I explore more fully in Flip It for a Different 
View, each section and chapter in the alternate portrait view has only 
one scrollable page. 

Create a New Text Object within a Flow 
All the flowing text in your book appears within text objects and, 
usually, you get these from the layouts used in your book. You may, 
however, need to create new text objects within a text flow for any 
pages that have special layout requirements where none of the 
standard page layouts serve. For example, if you need a page with 
text objects at the top and bottom but a large middle area for an 
illustration, you can do this by inserting a blank page between two 
existing pages that are part of the chapter’s or section’s text flow, 
creating a new text object at the blank page’s top that receives the 
flow from the previous page, and then creating a new text object at 
the bottom that receives its flow from the top object. 

Each text object that is part of a text flow shows controls at its borders, 
when selected, that you can use to alter the text flow. To select a text 
object, as opposed to selecting the text within it, click the object’s 
border. If the text object has no visible border, move your pointer over 
the object: when you get near any of its edges, a dashed-line appears 
that represents the border of the text object. 

Tip: Choose View > Show Layout Boundaries (Command-Shift-L) to 
see the borders of a text object and to make it easier to select the 
object. 

If the text object is at the beginning or in the middle of a text flow, 
you see a small blue rectangle at its upper-left and lower-right. If the 
text is at the end of a text flow, the rectangle at the lower-right displays 
a small arrow symbol instead of a blue rectangle. To also see blue 
connection lines showing the links between text objects in the flow; 
choose Format > Text Box > Show Connection Lines. 
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Spotting Unflowed Text with the Clipping Indicator
 

If the text object is at the end of a text flow but has additional 
text that hasn’t yet been flowed into another text object, a clipping 
indicator appears at the bottom-center of the object. You’ll see this 
indicator often when you edit text objects in a chapter, section, or 
page layout because the placeholder text in the templates frequently 
extends beyond the objects in the layout. The clipping indicator 
also appears at the bottom of stand-alone text blocks that contain 
more text than they have room to display. 

To create a new text object that is part of a text flow, do the following: 

1. Click the edge of the text object that contains the flow that you want 
to divert into a new text object so that you see the text flow control 
rectangle at its lower-right (either a blue rectangle or an arrow 
symbol). 

2. Click the text flow control rectangle. Your pointer changes its 
appearance and instructions appear (Figure 36). 

Figure 36: In the process of diverting the text flow to a new text 
object, the plus (+) badge on the pointer indicates that a new text 
object linked to the flow will be created where you click or drag. 

3. Elsewhere, either on the same page or the following page (and 
preferably in a blank area on the page), confirm that your pointer 
has a plus (+) badge and then drag to create a new text object with 
the shape and dimensions that you desire. (If you prefer, you can, 
instead, click to create the object and then move it and adjust its 
dimensions separately.) 
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When you finish, the text flows from the previous text object to the 
new one and from there, if necessary, into the flowing text objects 
that follow it in the section or chapter. 

Break a Text Flow 
In the rare case that you need to break a text flow, you use the same 
control rectangles described in Create a New Text Object within a 
Flow. When you break a text flow off, you don’t lose the text that was 
broken off, though: it remains, metaphorically dammed up, within 
the current last object in the flow. The clipping indicator  appears 
at the bottom-center of that object to let you know there is more text 
available to flow. 

Note: Don’t confuse deleting a page with breaking a text flow. When 
you delete a page that is part of a text flow, the text flow continues 
downstream to the next available page, if any, in the current chapter 
or section. 

Break with caution! The text objects downstream of where you 
break a text flow no longer participate in the flow, and cannot be 
made to join it again. You either have to create new pages for the text 
to flow into, apply a page layout that contains a flowing text block 
to a page that follows the break-off point, or make new objects to pick 
up the flow from where you broke it using the techniques described 
in Create a New Text Object within a Flow. 

Here’s how to break the text flow: 

1. Select the text object by clicking its border so you see its text 
flow control rectangles, and then click the blue rectangle  near 
the bottom-right of it to keep the text from leaving it. Instructions 
appear, and the pointer changes its appearance (as shown in 
Figure 36, previously). 

2. Whether you have chosen to show connection lines or not, move the 
pointer away from the text flow rectangle control and then back to 
it. Your pointer changes to show a minus (-) badge (Figure 37). 

3. Click the text flow control rectangle. An animated puff of smoke 
appears, and the link is broken. 
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Figure 37: On the verge of breaking the text flow where it 
flows out of the selected text object, note the minus (-) badge 
on the pointer. 

When you break a text flow, the text object remains selected so you can 
click a visible text flow control rectangle to redirect the flow elsewhere. 

Create a Stand-alone Text Object or Shape 
Although flowing text constitutes the spine of your book, it’s not 
the only sort of text you can have in your book. You’ve already seen 
some examples, such as the Introduction text that can appear at 
the beginning of chapters (see Change a Main Chapter Layout) or 
the Objectives text object that appears in some section layouts (see 
Change a Section Layout). iBooks Author has two tools on its Toolbar 
that enable you to add stand-alone text items to a page: Text Box 
and Shapes (Figure 38). 

Figure 38: The two leftmost tools at the center of iBooks Author’s 
default Toolbar provide ways to add stand-alone text to a page. 

To add a text box to a page, click the Text Box tool (or you can, if 
you prefer, choose Insert > Text Box). A small text box appears at the 
center of the currently displayed page, containing the placeholder text, 
“Type to enter text.” You can use the control handles to reshape and 
resize it, and you can use iBooks Author’s text formatting tools to alter 
the appearance of the text in it (Figure 39, left). 

Similarly, many of the shapes available from the Shapes tool (or from 
the Insert > Shape submenu) can hold text (Figure 39, right). These 
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shapes include rectangles, stars, ovals, diamonds, callouts, polygons, 
and quote bubbles—in fact, any available shape that has sufficient 
width and height to enclose text. Like a text box, shapes containing text 
can be reshaped, resized, moved around, and have their appearances 
modified. 

Figure 39: A text box (left) and a filled shape (right) can both 
contain text, and they can be resized, reshaped, and moved around. 

I’m not going to cover in detail all the ways you can modify the 
appearance of a text box or shape. However, here are the Inspectors 
you likely will use to do that: 

•	 Graphic Inspector: Use this to provide and customize a fill, 
stroke (that is, a visual boundary), and a shadow. You can also 
adjust the object’s opacity. 

•	 Metrics Inspector: This can modify the box’s or shape’s size, 
position, and its rotation (yes, you can have a text box displaying 
text at a 30-degree angle if you want). 

Tip: To rotate the shape but make the text horizontal, choose 
Format > Shape > Reset Text and Object Handles after you rotate it. 

•	 Text Inspector: This powerful Inspector gives you control over 
a whole range of text-related properties, including text color, 
background color, character spacing, inset from the borders of the 
object, bullets and numbering, text alignment, and much more. I 
suggest you spend some time playing with this Inspector and a text-
filled shape to discover what effects it can achieve. It’s a metric ton 
of power in a small floating window. 

In addition, you can, of course, format the text itself, which I cover 
next. 
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Format Text 
iBooks Author, like most other Apple applications that provide word-
processing capabilities, provides myriad menu commands, Inspectors, 
and tools for modifying text appearance and layouts. As I pointed out 
earlier, in Change the Book Cover, iBooks Author’s text manipulation 
commands are nearly identical to those in Pages, Keynote, and 
Numbers, and I won’t go into the details of how they all work here. 

However, I want to make one important point about text formatting 
in iBooks Author: the Format bar, which is visible by default in the 
iBooks Author main window (and, if it isn’t, choose View > Format 
Bar [Command-Shift-R]), is the best place to go first when you need 
to format text in your book (Figure 40). Why? Because iBooks Author 
produces books that can be read only on the iPad, and although the 
other tools available, such as the Fonts window (Format > Font > 
Show Fonts [Command-T]), work just dandy in iBooks Author, the 
menus on the Format bar provide only those fonts and styles that are 
available on the iPad. 

Figure 40: The Format bar. From left to right, here are the tools 
you can use to format text: Font Family menu, Typeface menu, Type 
Size menu, Text Color tool, Text Background Color tool, Text Style 
buttons, Justification buttons, Line Spacing menu, Columns menu, 
and List Styles menu. 

Along with the Format bar, you can, and should, use the Styles drawer 
to format paragraphs and arbitrary runs of text. This drawer, much like 
the Styles drawer in Pages, enables you to create standardized styles 
for characters, lists, and paragraphs, and to apply the styles in Apple’s 
templates. Formatting the text with styles helps you achieve visual 
consistency in your book. The iBooks Author Help topic, Format Text 
Using Styles, provides a concise illustrated description of how styles 
work in iBooks Author. 

Use Updating Text 
Updating text fields are runs of text that iBooks Author generates 
for you. To insert one of them into your text, choose it from the Insert 
menu. iBooks Author provides these updating text fields: 

•	 Section Title: This is something of a misnomer, since it doesn’t 
always insert a section title. For example, if you are working on 
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a chapter page that is not part of any section, choosing Insert > 
Section Title inserts the chapter title. 

•	 Section Number: Again, a misnomer, this inserts either the 
current section number or, if you are working on a page that isn’t 
part of a section, the current chapter number. By default, iBooks 
Author prefaces the number with the word Section or Chapter. 

•	 Page Number: Use this to insert the current page number in 
your text. This updating text is of particular use in chapter, section, 
or page layouts to provide a page number at the bottom or top of 
the page. Note that when you view a Landscape with Portrait book 
in portrait orientation, any updating page number within your text 
will show up as 1 (see Flip It for a Different View). 

•	 Page Count: Use this field to insert the current number of pages 
in your book. 

You can change what the Section Title and Section Number updating 
text fields say when you insert them: Control-click (or right-click) 
the updating text to modify what they display. You can Control-click 
a Section Title updating text field to have it show the chapter title or 
book title instead; for Section Number fields you can choose whether 
the section or chapter number is displayed, and whether it is prefaced 
by the word Section or Chapter. 

Take care when editing updating text fields! If an updating 
text field displays a chapter or book title and you edit it, you also 
end up editing not just the field but also the actual title of the chapter 
or book. 
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Add Your Assets
 
Textbooks, as I said back in What Is a Textbook?, contain much 
more than text. They’re usually loaded to the bindings with pictures, 
figures, charts, tables, and other non-textual items. These are not 
included merely to grab and hold the attention of otherwise bored 
students (though any teacher who’s wrangled a roomful of active 10-
year-olds will smile and say that is reason enough), but to provide 
additional instruction and insight. 

Multi-Touch books created by iBooks Author expand the range 
of available content to include audio, video, 3D models, interactive 
presentations, and more. I strongly recommend that you start by 
reading Add Illustrations and Figures (just ahead), to learn the 
essentials of how to add the available kinds of non-textual assets 
to your book so they appear how and where you want them, with 
the correct label, number, and caption. 

Once you’ve mastered the basics of asset placement, feel free to skip 
around to learn how to add different kinds of assets to your book: 

• Add Images, Shapes, Tables, and Charts
 

• Add Audio and Video
 

• Add Galleries (these are like slideshows)
 

• Add Keynote Presentations
 

• Add Interactivity (these images have clickable labels that provide 
more details and zoom the image) 

• Add Scrolling Sidebars and Pop-Overs
 

• Add 3D Objects (these COLLADA images can be rotated in your 
book) 

• Add HTML (these Dashboard widgets can be complex to create, 
but they can also add sophisticated options to your book) 

Finally, you can learn how to sanity-check a book’s alternate 
portrait view in Flip It for a Different View. 

(And what about quizzes, glossary items, and index entries? I cover 
those in the next chapter, Include Study Aids.) 
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Add Illustrations and Figures
 

iBooks Author provides you with many ways to illustrate your text. 
Some illustrations may consist of nothing more than page art, such as 
a separator line between columns of text, or a decorative image to fill 
out a page. Others may be complex assemblages of shapes and labels, 
such as a flowchart. Still others may be bar charts or pie charts, or 
tables of figures. And then there are images, videos, and the widgets 
described earlier in Plan for Interactivity. When I write “illustration” 
here, I mean any of these items, including widgets. 

Getting illustrations into your book is one thing; making them look 
the way you want once you get them there is another. In this topic 
I explain not only how to position them where you want them, I also 
explain how to add labels that automatically update, such as figure 
or chart numbers. 

Learn to Wrap 
How your book’s text flows over or around an illustration, and whether 
the illustration moves as you add or remove text, depends on the 
illustration’s placement properties; that is, whether it is a floating, 
inline, or anchored object: 

•	 Floating: A floating object stays on the page where you put it, and 
only moves when you manually reposition it. 

•	 Inline: An inline object is part of the text flow itself. It moves every 
time the characters surrounding it in the text move. For example, 
the small arrow pointer image following this word is an inline 
image. 

•	 Anchored: When an object is anchored, it has an anchor point 
within the text, but can appear anywhere on the page that you place 
it. Anchored objects stay on the same page as their anchors; if you 
add or remove text from the text flow and cause an anchor to move 
to a different page, the anchored object moves to that page as well, 
but retains its position on the page. 

For example, you can anchor an image to text that appears near the 
top of the page, but place the image itself in the lower-right corner; 
if the anchor moves to a different page, the object moves to that 
page as well and takes up its position in the lower-right corner. 
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See the next section, Lay Them Out like Widgets, to find out how 
to manipulate the anchor point. 

Remember the alternate portrait view: As noted in Change 
an Alternate Portrait Chapter Layout, unless a floating or anchored 
object in landscape view has a title or caption or can be made full-
screen (see Lay Them Out like Widgets), it vanishes in the alternate 
portrait view of a book based on a Landscape with Portrait template. 
You can use this feature to your advantage: untitled and uncaptioned 
floating or anchored graphics can be decorative in the normal 
landscape view, but not clutter the thumbnail track in the alternate 
portrait view. 

You control an object’s placement properties, and how text wraps 
around it, with the Wrap Inspector (Figure 41); a subset of wrapping 
options are available on the Format bar when an object is selected 
(Figure 42). 

Figure 41: The Wrap Inspector controls (what else?) how text wraps 
around a non-text object in your book. 

Figure 42: The Format bar offers quick access to wrap controls 
when an object on the page is selected. 
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iBooks Author imposes some rules on which objects can have which 
object placement properties: 

•	 Only images, single shapes, and grouped shapes (see Add Images, 
Shapes, Tables, and Charts) can be made inline. This rule implies 
the following rules... 

•	 Widgets, as well as shapes and images that have titles, captions, 
or both (see Lay Them Out like Widgets, immediately following), 
cannot be placed inline. However... 

•	 Any object can be made to float or be anchored. 

Note: You can slide an object that appears in the thumbnail track 
of the alternate portrait view anywhere along the track in that view 
without affecting its position in the landscape view. 

Tip: Hover your pointer above each of the wrap control icons in the 
Wrap Inspector to see what the control does. 
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Lay Them Out like Widgets 
You might guess that you would modify how objects placed on the page 
lay out by using the Layout Inspector, but you’d be wrong: whether it 
is a shape, a picture, a widget, a text box, or a chart, you actually lay 
it out with the Widget Inspector. For layout and interactivity purposes, 
iBooks Author treats every object on the page—with the exclusion of 
inline objects and text boxes that are part of the text flow—as a widget. 

With the Widget Inspector’s Layout pane (Figure 43) you can add 
titles and captions to an object, specify where they appear, put a 
background behind the object and specify its margin. 

Figure 43: The Layout pane of the Widget Inspector, where 
you can arrange the titles, captions, and backgrounds of on-page 
objects, and include a description that the iPad can read aloud to 
vision-impaired readers. 
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For some objects, you can use the Widget Inspector’s Interaction 
pane (covered near the end of this topic) to specify whether the 
object expands to fill the screen when the reader taps it, and whether 
it appears on the page as a thumbnail or at a size you set manually. 

Figure 44 shows the parts of a typical object on the page; in this case, 
the photograph laid out by the settings shown in Figure 43, above. 

Figure 44: An object on the page, with various parts labeled. 

Here are how the labeled items in Figure 44 (above) work, moving 
clockwise from the top: 

•	 Title: Check the Widget Inspector’s Title checkbox to include 
a title with a selected object. When you give an object a title, the 
object is placed within a default frame for the template. You replace 
the placeholder title text with the title you want. 

If you pick an option other than None from the Inspector’s Label 
pop-up menu, the title is prefaced by a label, such as Figure, and, 
optionally a number. Choose Edit Label Styles from the pop-up 
menu to modify the list of labels that can preface a title, the 
character style that is applied to the title, and the numbering 
scheme used for the title, if any. 

99 



         
            

     

          
          

              
         

          
              

             
            

         

         
              

             
    

         
             

      

            
         

    

        
     

         
          

      

•	 Margin: The amount of space, in typographer’s points (about 
1/72nd of an inch), between the object and its frame. The Margin 
slider in the Inspector controls this. 

•	 Caption: When this option is checked in the Inspector, additional 
placeholder text appears. Use the caption to provide additional text 
to describe the object. You can write more text than fits in the space 
provided: in the book, your reader can scroll through the text. 

•	 Size handles: These appear around any object on a page when 
it is selected. You know how they work: drag them to change the 
size and shape of the object. The size handles shown in Figure 44 
(above) affect the frame around the image; if you click the object 
within the frame, you see size handles around it instead. 

•	 Corner curve control: This tiny blue control appears at the top-
left of a framed object when you give it a title or caption with the 
Widget Inspector. Drag it along the edge of the frame to control the 
curvature of the frame’s corners. 

•	 Anchor point: This appears somewhere on the page for every 
anchored object. Drag it to whatever place in the text you want to 
be the object’s anchor (see Learn to Wrap). 

Tip: You can control where the title and caption appear in relation to 
the object within the frame by choosing an item from the Layout pop-
up menu in the Widget Inspector. 

Tip: You can specify whether the object has a colored or graphic 
background behind it in the Widget Inspector. You must select Title 
or Caption (or both) and then you can select Background. To adjust 
the appearance of the background and the border, or stroke, of the 
frame, use the Graphic Inspector or the Format bar. 
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Be accessible: If you’re concerned about vision-impaired readers 
(and you should be whether or not your book must comply with 
Section 508, the U.S. government’s requirement for providing 
access to the disabled—see http://www.section508.gov/index.cfm? 
fuseAction=Laws), you can type text that describes the object in 
the Accessibility Description field of the Widget Inspector. By default, 
iBooks Author populates this field with the title and label, if any; if 
there is a caption but no title, iBooks Author uses the caption. 

VoiceOver on the iPad reads the accessibility description aloud when 
a reader taps the object in the book or drags a finger over it. 

Finally, the Widget Inspector has a second pane: Interaction. Although 
this pane comes fully into play when managing an interactive object, 
as you’ll see elsewhere in this chapter, it has two options that affect the 
layout of floating and anchored objects: the Make Full Screen on Tap 
and the Full-Screen Only checkboxes. 

These two checkboxes work together like this: 

•	 For an object to appear on the page at any size you manually set, but 
to expand to fill the iPad screen when the reader taps it, check Make 
Full-Screen on Tap. 

•	 For an object to appear as an automatically-sized thumbnail in the 
text but to expand to fill the screen when the reader taps it, check 
Make Full-Screen on Tap and then check Full-Screen Only. You 
cannot check Full-Screen Only unless Make Full-Screen on Tap is 
already checked. 

When an object appears as a thumbnail in the text, you get an Edit 
Frame button attached to the thumbnail: click it and you can 
customize the frame of the full-screen version that your reader sees 
in iBooks. 

Make Full Screen on Tap and the Alternate Portrait View: 
In a book based on a Landscape with Portrait template, floating or 
anchored objects appear as thumbnails in the alternate portrait view 
when Make Full Screen on Tap is checked, whether or not the object 
has a label or caption. 
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Add Images, Shapes, Tables, and Charts 
As you saw in Change the Book Cover, you can drag an image from the 
Media browser or the Finder (or even, for that matter, from another 
application such as a Web browser) into an image placeholder in 
iBooks Author. However, dragging images isn’t just for placeholders: 
you can drag any compatible image (that is, JPEG, PNG, or GIF) into 
iBooks Author to put it on a page. By default, the dropped image 
becomes an anchored object, but you can change that with the Wrap 
Inspector or the Format bar (see Learn to Wrap). 

Tip: If you hold down Command while dragging and dropping an 
image, iBooks Author places it on the page as an inline object rather 
than as an anchored one. 

As I also described previously in Create a Stand-alone Text Object 
or Shape, you can use the Insert menu or the respective tools on the 
Toolbar to put shapes and text boxes onto a page. By default, the 
objects are placed as floating objects, but, again, a trip either to the 
Wrap Inspector or the Format bar can change that. 

You can build complex objects by adding shapes, images, and text 
boxes to a page, customizing their appearance, moving them around, 
arranging them with the commands on the Arrange menu, and then 
grouping them all together by choosing Arrange > Group (Command-
Option-G). Figure 45 shows a simple grouped object that has been 
given a title and a background with the Widget Inspector. 

Figure 45: Build your own diagram from shapes and text boxes. 
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Tip: Once you group several objects into a grouped object you can 
group it with other objects, themselves either simple or grouped. 
Groups within groups within groups... 

You can even build tables or charts out of assemblages of objects—but 
you don’t have to: iBooks Author provides both a Table tool on the 
Toolbar that inserts a table on the page and a Charts tool right next to 
it from which you can choose a chart type from a healthy assortment. 
Figure 46 shows a pie chart and grain table created by these tools. 

Figure 46: The Table and Charts tools make the presentation of 
statistics and tabular data easy. 

You can produce sophisticated charts and tables with their respective 
Inspectors: the Table Inspector and Chart Inspector provide almost 
exactly the same functionality as their counterparts in Apple’s Pages. 
The iBooks Author Help topics, Tables and Charts, are reasonably 
thorough, so I won’t dwell on the functionality of the available 
Inspectors and commands here. 

Neither charts nor tables are static within iBooks Author: 
the Table Inspector even provides a basic formula editor so your table 
can do simple calculations, and the Chart Inspector has a Chart Data 
Editor that updates the chart’s appearance when you change the 
data. However, the calculation and chart update capabilities only 
exist in iBooks Author: the charts and tables that the reader sees in 
iBooks are static snapshots of your charts and tables. 
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By the Numbers
 

iBooks Author can even represent complex mathematical equations 
in a Multi-Touch book using LaTeX and MathML. Read the Apple 
article, “iBooks Author: About LaTeX and MathML support” (http:// 
support.apple.com/kb/HT5321) for a complete description of this 
capability, along with specific examples. 

Add Video and Audio
 

The tools and templates provided by iBooks Author go to great lengths 
to create the illusion that Multi-Touch books are “just like real books.” 
Once a book begins to talk and its illustrations start to move, however, 
that illusion is shattered. But that’s a good thing. 

Adding a movie or an audio clip to your book consists of a single step: 
drag a compatible video or audio file from the Finder or from iBooks 
Author’s Media browser to the page. When you do, iBooks Author 
immediately creates a Media widget and places the media you dragged 
within it (Figure 47). 

Figure 47: Media widget with a video and a customized background. 
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iBooks Author 1 limited you to just a few specific audio and video 
formats; iBooks Author 2 loosens those restrictions by making use of 
the QuickTime software included in Mac OS X to convert and optimize 
the media you place in your book into a format that the reader’s iPad 
can handle. 

Note: The media conversion and optimization step can take some 
time, ranging from seconds for a very short media file to many 
minutes for a longer file. See http://support.apple.com/kb/ht3775 
for a list of the media formats that QuickTime can support. 

Once your Media widget is in place, you can customize it with the tools 
and techniques described earlier in this chapter, in Add Illustrations 
and Figures: change its background, adjust its size and borders, modify 
its title and caption, and so on. 

You also want to look at, and possibly adjust the settings, on the 
Interaction pane of the Widget Inspector (Figure 48). 

Figure 48: The Interaction pane of the Widget Inspector provides 
these controls when a Media widget containing video is selected. 
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With the Interaction pane, you can do the following with a Media 
widget: 

•	 Control playback: You, as the book’s author, can use the controls 
under the Controls heading to preview your media. These controls 
do not affect the published book; they’re for your convenience. 

Tip: Although you can’t use the controls under the Controls heading 
to set a start and stop point for your media’s playback, QuickTime 
Player in Mac OS X offers a Trim function you can use to trim a video 
or audio file before you import it into iBooks Author. 

•	 Control looping: The Repeat pop-up menu controls whether 
the widget loops back to the beginning and starts playing again or 
simply stops when it reaches the end. Looping media might be used 
when your readers need to listen repeatedly to short pronunciation 
samples or to view short videos of complex processes that require 
repeated viewings to understand. 

•	 Restrict playback to full-screen: Available only for video, the 
Full-Screen Only option restricts the widget to play its contents only 
in full-screen (in which case the widget on the page is displayed as a 
thumbnail that the reader must tap). You should consider choosing 
Full-Screen Only if the media contents require the iPad’s full screen 
to appear to their best advantage, or if space is at a premium on the 
page where the widget appears. 

•	 Choose a poster frame: A poster frame is the video frame that 
appears before the video starts playing; this option is not present 
for audio-only media widgets. If the video in a widget begins with 
a blank frame, moving the Poster Frame slider to select a nonblank 
poster frame from elsewhere in the video gives your widget a 
more interesting appearance. When you click the poster frame in 
iBooks Author, the video plays from where you set the poster frame; 
however, when a reader taps the poster frame in the finished book 
on an iPad, the video plays from the beginning. 
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When you add an audio file, the top portion of the Layout Inspector’s 
Interaction pane provides three options for playback controls (see 
Figure 49 a little bit ahead for examples): 

•	 Button: This option presents the audio playback control as a 
simple button within the frame that contains the widget’s label 
and caption. In the finished book, your reader can tap this button 
to start and stop playback. If the reader stops playback before the 
audio has reached the end, the next tap picks up where the playback 
left off. iBooks Author tries to conserve space on the page with 
this option: you cannot adjust the width or height of the frame 
containing the widget. I recommend, therefore, that you keep your 
captions and labels short when you use this option so you don’t end 
up with long skinny swaths of text in the widget frame. 

•	 Scrubber bar: Use this to provide readers with the most control 
over audio playback. Readers can drag the playback head in the bar 
to move to any part of the audio they wish to hear. You can control 
the width and height of the widget on the page: the wider you make 
the widget, the wider the scrubber bar becomes, making it easier 
for a reader to position the playback head accurately. 

•	 Image: An image that you drop on the widget provides the 
playback control with this option; for example, you might use 
a picture of Thomas Edison as a playback control for an audio 
recording of the inventor. When the reader taps the image on the 
iPad, the playback commences, a second tap stops playback, and 
a third tap starts playback again from the beginning of the audio. 
In iBooks Author, however, clicks on the image do not start or 
stop playback: instead, you can use the playback controls in the 
Widget Inspector’s Interaction pane to play the audio. 
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Figure 49: Media widgets with audio, showing the three ways that 
audio can be presented. 

Note: The playback controls in Media widgets look somewhat 
different in the iBooks Author environment than they do on the iPad, 
which presents the standard iPad audio and video playback controls 
that users are accustomed to seeing. 

Go light on the heavy media: As compelling as video and audio 
can be, and although Media widgets make for great demos when you 
show your book, I suggest that you use video and audio sparingly. 
Media files, especially video files, can consume huge amounts of 
storage space and bloat your book. Remember that students will read 
your book on iPads that may not have more than 16 GB of storage. 
Don’t overload the student’s virtual backpack with an unnecessarily 
data-heavy book. 

108 



  

              
           
            

            
         

 
           

            
            
             

          

         

           
           

  

              
             
          

           
             

           

Add Interactive Presentations
 

Way back in Plan for Interactivity, I provided a tour of the widgets that 
iBooks Author offers. Then, in the preceding section, Add Video and 
Audio, I described the Media widget. Here in this section, I describe 
how to set up the rest of iBooks Author’s widgets—except for the 
Review widget, which I cover in Add Study Questions (and Answers). 

Add Galleries 
A page provides a constrained area within which to present your text 
and pictures. The Gallery widget offers a good solution when you need 
more than one or two pictures to accompany, illustrate, or amplify a 
point in your text: it can contain an arbitrary number of pictures and 
display them one at a time with just a tap or swipe. 

To put a Gallery widget in your book, do this: 

1. From the Widgets pop-up menu in the Toolbar, choose Gallery, or 
choose Insert > Widget > Gallery. An empty Gallery widget appears 
on the page. 

2. From the Finder drag one or more image files, or even a folder of 
images, to the Gallery widget or to the Gallery Media field in the 
Widget Inspector’s Interaction pane (Figure 50). If you prefer, you 
can, instead, click the Add button below the Inspector’s Gallery 
Media field and choose files from a dialog. Or you can drag images 
to the widget or to the Interaction pane from the Media Browser. 
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Figure 50: Use the Interaction pane to add, remove, arrange, and 
provide accessibility descriptions for images in a Gallery widget. 

3. Use the controls in the Interaction pane to arrange the order of 
the images, to add or remove images, and to provide accessibility 
descriptions (see the earlier note, Be Accessible). 
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4. Choose whether the widget displays thumbnails to allow readers to 
choose a specific picture in the Gallery widget to view (Figure 51). 
Without thumbnails, readers swipe through the images to navigate. 

Figure 51: Gallery widget showing thumbnails and a caption. Each 
image can have an individual caption. 

5. On the Widget Inspector’s Layout pane, choose whether the Gallery 
widget provides separate captions for individual images. 

6. Customize the placement and appearance of the widget on the page 
using the techniques described in Lay Them Out like Widgets. 

7. If necessary, adjust the widget’s anchor point (it is anchored by 
default) or make it float (see Learn to Wrap). 

You can use a JPEG, GIF, or PNG image file in a Gallery widget. On 
an iPad with a Retina display, the widget can display images having 
no more than 2048 pixels along their longest sides, and will scale large 
ones down. On iPads with less commodious displays, pictures are 
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scaled to a longest side dimension of 1024 pixels. The maximum size 
for a Gallery image is 25 megapixels (5000 by 5000 pixels), and the 
maximum file size is 50 MB. 

Tip: For better performance on all iPads, especially older ones, use 
images having no more than 1024 pixels along their longest sides. 

Tip: Click each image in the widget and use the Edit Mask popover 
that appears to scale the image within the widget and adjust which 
part of it is visible. 

Add Keynote Presentations 
As I mentioned in Plan for Interactivity, you can present Keynote 
presentations (and PowerPoint presentations that you have converted 
to Keynote) with the Keynote widget. Keynote presentations present 
narratives that comprise both pictures and text (usually in bullet-point 
form), and they are often useful for providing an animated and 
illustrated overview of a topic. 

However, the Keynote widget in iBooks Author does not have all of the 
presentation capabilities of the Keynote application. In particular, it 
has these limits: 

•	 Some slide transitions are not available. 

•	 Self-playing presentations are not available. 

•	 Voice-over narrations are not available. 

•	 Presentations larger than 2048×1536 pixels on Retina-screen iPads 
or 1024×768 on other iPads are scaled down. 

Note: iBooks Author requires Keynote version 5.2 or later, and 
can import only Keynote files that have been exported as HTML. 
If Keynote is installed on your Mac, you can choose Keynote files 
directly (they have .key filename extensions), and iBooks Author 
launches Keynote and silently exports the file into HTML form before 
importing it. Keynote is available from the Mac App Store. 
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Here’s how to add a Keynote presentation to your book:
 

1. From the Widgets pop-up menu in the Toolbar, choose Keynote, 
or choose Insert > Widget > Keynote. An empty Keynote widget 
appears on the page. 

2. Drag a Keynote file, or a folder containing a Keynote file that has 
been exported as HTML, onto the widget. Or, choose a Keynote 
file from a dialog by clicking the Choose button in the Widget 
Inspector’s Interaction pane (Figure 52). 

Figure 52: You can choose a Keynote file and display navigation 
controls within the Keynote widget using the Widget Inspector’s 
Interaction pane. 

3. Choose whether to display navigation controls in the widget (see 
Figure 53), and whether to restrict it to full-screen display only 
(I describe full-screen only display in Add Video and Audio). 
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Figure 53: A Keynote widget with a label and a caption, and 
with transport controls that the reader can use to page through 
the presentation. 

4. Using the techniques described in Lay Them Out like Widgets, 
adjust the placement and appearance of the widget on the page. 

5. Optionally, adjust the widget’s anchor point or make it float (see 
Learn to Wrap). 

Note: You can replace the Keynote file in the widget by dragging a 
different file to it; the Keynote file shown in iBooks Author behaves 
like a placeholder, as you can see in Figure 53 (above). 

But it doesn’t work! Well, no and yes: a Keynote widget in 
iBooks Author on your Mac shows you only a static image of your 
presentation. Presentations do work in your book when you read it 
on the iPad, of course; otherwise, what would be the point of them? 
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Add Interactivity 
Here’s the difference between the Gallery widget that you’ve already 
seen (Add Galleries) and the Interactive Widget: galleries use one 
space to show multiple pictures, while Interactive Images use one 
space to show multiple views of a single picture. Use the Interactive 
Image widget to present labeled, detailed close-ups of different parts 
of a large picture. An Interactive Image has one or more labels that, 
when tapped, zoom the image in to show a more detailed view and, 
optionally, display a detailed description. 

When your reader first opens a page with an Interactive Image widget, 
the widget presents its default appearance, which is normally the full 
image with its labels visible (although you can be perverse and hide 
some labels in the default view, I don’t recommend it). Figure 54 
shows an Interactive Image widget with three labels. 

Figure 54: An Interactive Image with labels and transport controls. 
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Follow these steps to insert and configure an Interactive Image widget: 

1. From the Widgets pop-up menu in the Toolbar, choose Interactive 
Image, or choose Insert > Widget > Interactive Image. 

An empty widget appears on the page showing two placeholder 
interactive labels. 

2. Drag an image to the widget from the Finder or Media browser. 

Because Interactive Image widgets are meant to show large images, 
you can use an image on an iPad with a Retina display that has a 
dimension along its longest side of 4096 pixels; larger images are 
scaled down to 4096 pixels. Although you can use such images 
on an iPad with a lower-resolution display, images with a longest 
dimension of 2048 pixels provide improved performance. 

3. Click a label. 

The widget zooms in on the label and expands it to show a
 
description (Figure 55).
 

Figure 55: Adjusting a view’s label position in an Interactive Image. 
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4. Connect the label to the part of the picture you want to label by 
dragging the endpoint of the line. If necessary, use the popover’s 
slider to zoom out so you can see more of the picture, or to zoom 
in so that you can place the endpoint more precisely. 

5. Position the label on the picture by dragging the line near where it 
enters the label. 

6. Customize the label’s name by clicking the text at the top of the 
label and then editing it. 

7. Customize the label’s description (or delete it)—click the text to 
activate it for editing. 

8. Adjust the view of the image that will appear in iBooks when the 
label is tapped by moving the slider in the popover below the image 
and dragging the image in the frame. To finalize and record the 
view’s magnification and position, click Set View. 

9. Click Default View in the Widget Inspector’s Interaction pane 
(Figure 56, ahead slightly) so you can see the full image, click 
another label, and repeat Steps 4–8. 

Tip: You can also use the Inspector to show transport controls 
below the image, and to place the label’s description in a sidebar 
that appears over the image instead of attached to the label itself. 

10. If you need additional labels and views, in the Widget Inspector’s 
Interaction pane, click the Add button, set up the label and view 
using the steps above, and then, if desired, go back to the default 
view and add another view. 

11. Once you’ve added all your views, I recommend that you provide 
accessibility descriptions in the Widget Inspector’s Accessibility 
Description area for each view. Use the Inspector’s pop-up menu 
to choose the accessibility descriptions for each part of a view: 
the view’s label, the target that the label points to, and so on. The 
VoiceOver feature on the iPad reads these descriptions aloud to 
users. (Note that choosing Default View shows the accessibility 
description for the widget as a whole.) 
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Figure 56: Set multiple accessibility descriptions, show optional 
controls, and rearrange the views with the Interaction pane. 

Tip: In the Interaction pane of the Widget Inspector, you can drag 
any of the listed views (except the Default View) up or down to 
change the order in the list. 
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Add 3D Objects 
You probably won’t need the 3D widget for a literature textbook, but 
for many other kinds of textbooks—chemistry, engineering, biology, 
mathematics—displaying a three-dimensional object and allowing the 
reader to move it around is a wonderful capability. 

iBooks Author’s 3D widget can display any 3D model that uses the 
COLLADA format (file extension .dae). Unfortunately, you can’t 
manipulate the object in iBooks Author; to take your model for a spin, 
you must preview or export your book and view it in iBooks on an iPad. 

What’s a COLLADA file? If you don’t know what a COLLADA 
file is, this widget may not be for you. If you do know, you probably 
know more about such files than I do. If you’re curious about 
COLLADA, go to http://en.wikipedia.org/wiki/COLLADA. To create 
a 3D model, try Trimble SketchUp (http://www.sketchup.com/). 

Like the other widgets we’ve seen, getting the model into your book 
is a drag-and-drop operation: 

1. From the Widgets pop-up menu in the Toolbar, choose 3D, or 
choose Insert > Widget > 3D. An empty widget appears on the 
page showing two placeholder labels. 

2. Drag a .dae file to the widget from the Finder, or, in the Interaction 
pane of the Widget Inspector (Figure 57), click Choose and select 
a file from the dialog. 

Figure 57: Adjust the rotation of a 3D object with the Widget 
Inspector’s Interaction pane. 
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3. From Object Rotation pop-up menu, choose whether the object can 
rotate freely, only on the horizontal axis, or only on both axes. 

4. Optionally, select whether the object automatically rotates when the 
reader comes to the page that has the widget. 

Like any other widget, you can modify its frame, position, wrapping, 
anchor point, labels, and background using the techniques described 
in Lay Them Out like Widgets and Learn to Wrap. 

Your 3D image will initially appear in your published book laid out as 
you created it, but when a reader taps it in order to manipulate it, the 
image zooms to full-screen size, with its label and caption showing. 

Add Scrolling Sidebars and Pop-Overs 
iBooks Author provides two widgets meant for textual digressions and 
supplements: the Scrolling Sidebar and the Pop-Over. These widgets 
can contain large quantities of formatted text, along with images, 
shapes, and additional text boxes—whatever you need, other than a 
widget, to make your point. You’ve read about what they are good for 
and seen examples, much earlier, in Plan for Interactivity; now, here’s 
how to create them: 

•	 To add a Scrolling Sidebar: Display the page to which you 
want to add the sidebar and then choose Insert > Widget > Scrolling 
Sidebar. The sidebar is placed as an anchored object on the page, 
with a background and text style suitable for the template you are 
using (Figure 58). 

Figure 58: A new unpopulated Scrolling Sidebar, ready to be 
customized and filled with content. 
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•	 To add a Pop-Over: Display the page on which you want to put 
the image that triggers the Pop-Over and then choose Insert > 
Widget > Pop-Over. A placeholder for the image, along with the 
revealed Pop-Over, is placed as a floating object on the page 
(Figure 59). You can then drag an image onto the placeholder to 
serve as a trigger for the Pop-Over. 

Figure 59: A new Pop-Over, ready for its picture and content. 

Note: For a Landscape with Portrait book in its alternate portrait 
view, a Pop-Over does not appear when you double-click its trigger 
image in iBooks Author; the Pop-Over does appear as expected, 
however, when you view the alternate portrait view on an iPad. 

Here are some of the ways you can customize these two widgets: 

•	 Add text and objects: Type or paste text directly into the 
Scrolling Sidebar or Pop-Over; iBooks Author provides helpful 
placeholder text that tells you how you can get started. You can add 
text boxes and shapes to the contents of either widget by selecting it 
and then choosing the appropriate command from the Insert menu. 

•	 Add labels and captions: By default, Scrolling Sidebars and Pop-
Overs have no labels or captions, but you can add them with the 
Widget Inspector. Select the Scrolling Sidebar or the image that 
triggers the Pop-Over and use the controls in the Widget Inspector’s 
Layout pane. 
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• Change the text background and border: You can change 
the color of the background behind the text and the border that 
surrounds it in a Scrolling Sidebar or Pop-Over. Select the Scrolling 
Sidebar, or double-click the Pop-Over’s trigger image, and then use 
the Fill and Stroke controls in the Graphic Inspector. In addition, 
you can use the Graphic Inspector to add a shadow to a Scrolling 
Sidebar or to a Pop-Over’s image trigger. 

• Adjust its size: Drag the size handles around a Scrolling Sidebar 
or Pop-Over. A Scrolling Sidebar also offers a corner curve control 
(see Lay Them Out like Widgets) you can adjust to give it rounded 
corners. 

Conserve space: You can make the trigger image of a Pop-Over 
as big as you like (or, at least, as big as 5000×5000 pixels); 
however, remember that a Pop-Over’s main benefit is to conserve 
space on the page for the book’s main content by concealing a 
large digression “inside” of a small image. 

•	 Adjust how text wraps around it: Select a Scrolling Sidebar 
or a Pop-Over’s image trigger and adjust how text wraps around it 
using the Wrap Inspector (see Learn to Wrap). 

Tip: The image trigger for a Pop-Over is the one widget component 
that can be made inline. You can use this to create a small graphic 
object inline with your text that produces a Pop-Over when readers 
click it—perfect for annotations. 

Add HTML 
The HTML widget can provide forms of interactivity not anticipated 
by the iBooks Author developers. The name is a misnomer because it 
really displays Dashboard-type widgets, like the ones that appear on 
your Mac’s Dashboard. Although Dashboard widgets contain HTML 
code, they also contain other kinds of code, and can contain and 
display images and even audio and video. 

These Dashboard-type widgets (not to be confused with iBooks 
Author’s own widgets) are often developed with Apple’s free Xcode 
developer tool suite (http://itunes.apple.com/us/app/xcode/ 
id497799835). Other applications, however, such as Tumult’s Hype 
(http://tumultco.com/hype/) can also produce Dashboard-type 
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HTML widgets (I used Hype to create the Cheshire Cat widget that 
you’ll see shortly). 

Note: You can insert only widgets with HTML, CSS, or JavaScript 
code; for example, Dashboard widgets with Cocoa plug-ins or similar 
compiled code can’t be added to an HTML widget. See the support 
document “iBooks Author: About HTML widget creation” (http:// 
support.apple.com/kb/HT5068) for more about how to prepare HTML 
widgets and the restrictions on what they can contain. 

Note: HTML widgets can contain and play .mp4 video files and .m4a 
audio files only. Unlike the Media widget, which uses QuickTime to 
optimize audio and video for use in your book, the media inside of 
an HTML widget must already be in one of those two formats. In 
addition, DRM-protected media won’t play in an HTML widget (well, 
what did you expect?). 

If you have a widget handy that you want in your book, here’s how 
to put it there: 

1. From the Widgets pop-up menu in the Toolbar, choose HTML, or 
choose Insert > Widget > HTML. An empty widget appears on the 
page just waiting for your widget. 

2. Drag the widget file (they have a .wdgt file extension) to the HTML 
widget from the Finder, or, in the Interaction pane of the Widget 
Inspector, click Choose and select a file from the dialog. 

The widget appears in your book as a thumbnail: HTML widgets play 
only in full-screen when the reader taps them. 

You can, however, select the widget in iBooks Author and click the 
Edit HTML button that appears. This puts the widget in full-page view 
in iBooks Author, where you can possibly try it out, but definitely 
adjust its label and caption (Figure 60). I say possibly because iBooks 
Author’s Help says that not all compatible HTML widgets work in 
iBooks Author, even if they do work iBooks on an iPad. However, the 
widget I created (shown in Figure 60) does work in the Edit HTML 
view (that is, the Cheshire Cat fades out and back in when it is clicked). 
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Figure 60: An HTML widget being edited. 

Flip It for a Different View
 

When you make a book using a Landscape with Portrait template, 
the landscape view of your book provides more features and layout 
capabilities than its alternate portrait view. Nonetheless, if you allow 
readers to read your book in its alternate portrait view, you should 
take care that your book looks the way you want in that view. 

Wait, what? Portrait view is optional? Yes, kids, it is. To 
restrict a Landscape with Portrait book to the landscape view only, 
go to the Document pane of the Document Inspector and check 
Disable Portrait Orientation. Now you don’t have to mess with it at 
all. And, if you use a Portrait Only template, none of what I describe 
in this section pertains to that template. Nonetheless, you should still 
read this section, because you may change your mind for your next 
book, if not your current one. 
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First, consider what the alternate portrait view does to your content 
and think about why your readers might want to use that view. In 
alternate portrait view, the text of each chapter and section appears 
in its own single page: at the top is a title banner, which is followed by 
a scrollable page that accommodates the entire text flow of the chapter 
or section—rather like many common Web page designs. Any widgets 
or illustrations (other than inline objects) may appear as thumbnails 
in the margin beside the text. 

As a result, the alternate portrait view presents text front and center, 
while it relegates any Scrolling Sidebars and attractively distracting 
illustrations, whether passive or interactive, to unobtrusive thumbnails 
until a reader’s tap summons them. The alternate portrait view, 
therefore, helps readers focus on the main textual content of a book. 

Generally, the alternate portrait view works best for books that rely 
primarily upon the main text flow and that contain relatively few 
figures and interactive illustrations. If you use too many illustrations 
and widgets, you’ll end up with a pile-up in the thumbnail track, such 
as the one shown in Figure 61, which depicts the alternate portrait 
view of the Multi-Touch book companion to this book, Take Control 
of Getting Ready for iBooks Author, and which illustrates one of the 
reasons that I disabled the alternate portrait view in that book. 
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Figure 61: Thumbnails can pile up in a visual train wreck if you have 
too many in an alternate portrait view. 

I’ve already discussed the mechanics of laying stuff out in the alternate 
portrait view as well as the main view, so here I briefly mention 
additional steps you should take for the alternate portrait view: 

•	 Check your anchors: When you create figures and widgets, 
they normally start as anchored objects (see Learn to Wrap). In 
landscape view, you usually don’t have to think much about where 
the anchor is located because it is placed, by definition, on the same 
page as the object it anchors—even if the anchor’s initial position 
is far from the passage with which the object is associated (anchors 
often initially appear at the top-left of the current page, and they 
don’t move when you move the objects they anchor elsewhere on 
that page). 
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The alternate portrait view, on the other hand, has only one page, 
and it displays objects only as thumbnails. When you view a section 
or chapter in that view, the thumbnails may show up farther from 
the text to which they belong than you’d like. Therefore, remember 
to drag your anchor to the right location in the text whenever you 
place an object on the page in landscape view, and then to check 
where the thumbnail shows up in the alternate view. You can 
slide thumbnails around to make fine adjustments, but you can’t 
rearrange their order in the alternate view, so make sure the order 
of the anchors in the landscape view is, um, in order. 

•	 Check your tracks: You can show or hide the thumbnail track 
with the Layout Inspector on a section by section basis, including in 
any chapter opening material that appears before the chapter’s first 
section. I suggest you browse through your book in the alternate 
portrait view and decide on a section by section basis whether the 
thumbnail track needs to be visible. For example, if a section has no 
thumbnails, you can turn off the track and gain screen real-estate. 

•	 Check your sanity: You can’t assume that iBooks Author has 
done the right thing by your content in the alternate portrait view 
just because you’ve polished the landscape view to a fine gloss. 
Whenever you finish composing and laying out a section or chapter, 
give it a once-over in the alternate portrait view. This sanity-check 
pass through your content can occasionally alert you to easily 
fixable problems in the alternate view. It’s also a good way to give 
your text a final proofreading pass without being distracted by your 
book’s various figures and widgets. 

127 



              
            

   

            
         

            
           

          
           

      

    

           
           

           
          

           
            

         
       

        
            

           
            

          
    

Include Study Aids
 
Well, yes, your whole book is, or can be, a “study aid,” but here 
I want to discuss three sets of useful tools and techniques for 
advancing your pedagogical aims: 

• The Review widget, and how you can use it to help readers 
review and think about the material they’ve read (just ahead) 

•	 The Glossary tool, and how you can exploit it as both a teaching 
tool and a conceptual index to your book (Create and Organize 
a Glossary) 

•	 Bookmarks and hyperlinks, and how you can use them to Cross 
Reference Your Book and even access that big book we call the 
Internet 

Pay attention; there may be a test.
 

Add Study Questions (and Answers)
 

A feature you’ll often find in textbooks are study questions, either 
sprinkled throughout the book or tucked away at the end of each 
chapter or section. iBooks Author provides the Review widget for you 
to use to make interactive versions of these time-honored textbook 
staples. With the widget, you not only can provide questions but the 
answers as well so readers can evaluate their mastery of the materials. 

Unfortunately, until the gnomes and boffins in the vast research 
catacombs beneath Apple’s headquarters in Cupertino develop reliable 
artificial-intelligence-based text analysis algorithms that can run on 
a student’s iPad, you can forget about adding study questions to your 
book that parse essay questions or even short answer quizzes. But 
what you can provide are study questions of the multiple choice and 
matching variety. Figure 62 shows a simple example of the match-
the-label-with-the-image variety of study question. 
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Figure 62: A rudimentary labeling question as it appears in iBooks 
Author with the answers in place; on the iPad the reader drags the 
labels from beneath the images to their correct positions and then 
taps Check Answer. 

The Review widget can contain multiple questions and can mix types; 
for example, a simple multiple choice question can be followed by a 
matching question or a labeling question. You can arrange the order 
of the questions however you like. On the iPad, the widget allows the 
reader to navigate between questions, answer the questions, check the 
answers, and re-answer a question if the first answer was incorrect. 

Don’t be testy: The widget doesn’t keep track of right answers, so it 
can’t be used for graded quizzes. Design your questions, therefore, to 
help readers reinforce the information that they have read (and seen, 
and heard) in your textbook. 
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To add a Review widget, choose Review from the Toolbar’s Widget 
pop-up menu, or choose Insert > Widget > Review. A Review widget 
appears on the current page as an anchored object (see Learn to Wrap) 
with a default four-item multiple choice question (Figure 63). The 
text of the question, its answers, and its label are all placeholder text 
that you can modify. 

Figure 63: The default question in a newly placed Review widget. 
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You manage the order of the questions and the number of possible 
answers for each question with the Interaction pane of the Widget 
Inspector (Figure 64). 

Figure 64: Create and arrange study questions, and provide 
accessibility descriptions, with our old friend, the Widget Inspector. 
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Here are the capabilities that the Interaction pane for the Review 
widget offers you: 

• Add questions: Click the Add button below the Questions list 
to see a pop-up menu of question types from which you can choose. 

• Remove questions: Click a question, and then click the Remove 
button below the question list. 

•	 Arrange questions: Drag a question up or down in the Questions 
list. 

•	 Specify the number of answers to a question: Click the 
number to the right of a question in the Questions list and choose 
the number of possible answers, from two to six. 

•	 Provide accessibility descriptions: Use the pop-up menu in 
Accessibility Description area to select the different elements of 
each question (such as the question itself or the images that appear 
in a question), and use the field beneath the pop-up menu to 
provide a textual description for the selected question element. 

And here are the types of questions you can add to a Review widget 
and how you set them up: 

• Multiple choice (four varieties): The Add button pop-up 
menu offers one text-only multiple-choice question, two multiple-
choice questions that include an image placeholder (one above the 
list of possible answers and one beside the list), and one multiple-
choice question where the reader must select from among multiple 
images. You set up the question by doing the following: 

‣	 If the question includes images, drag images from the Finder 
or the Media browser to the image placeholders, and adjust each 
image’s magnification and mask with the popover that appears 
beneath an image when you double-click it. 

‣ Select and type replacements for placeholder text. 

‣	 Specify an answer by clicking the right answer’s choice circle to 
place a green checkmark in it (refer back to Figure 63). 

Tip: To specify more than one possible correct answer in a multiple 
choice review, hold down the Command key and click an answer. 
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•	 Drag label to target: This type of study question consists of an 
image and from two to six labels. When readers see the question, 
the labels initially appear beneath the image, and readers answer 
the question by dragging the labels to where they belong on the 
image. The image shows the possible label locations, and a location 
highlights when a label is dragged near it. You prepare the question 
like this: 

‣	 Drag the image to the question’s image placeholder and adjust it 
with the image editing popover (double-click the image to open 
the image editing popover). 

‣	 Replace the placeholder text in the labels with your own text. 

‣	 Specify the correct answer by dragging the labels to where they 
belong on the image. 

•	 Drag thumbnail to target: This question type is much like the 
drag label to target question; however, here the labels are thumbnail 
images. When readers see the question, the thumbnails initially 
appear beneath the image, and they behave like the text labels in the 
add label question type when dragged. 

To prepare the question, do this: 

‣	 Drag the main image to the question’s image placeholder and 
adjust it with the image editing popover. 

‣	 Drag images into each of the thumbnails, and, again, adjust each 
with the popover. 

‣	 Specify the correct answer by dragging the thumbnails to where 
they go on the image. 

Note: iBooks Author enables you to set up the questions, but to try 
them you must export or preview the book in iBooks on an iPad. 
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Create and Organize a Glossary
 

The Glossary tool that iBooks Author provides is a little hard to wrap 
one’s neural wiring around, partly because the name is misleading. 
True, it can provide a glossary as the name promises, but it can also 
be used to build an index for a book, or to provide citations and 
annotations, or to spawn a chimerical (in the biological sense) index-
cum-glossary beast that can carry footnotes on its back. To switch 
metaphors in mid-stream, it’s a Swiss-Army glossary. 

Note: In this section, when I use the term glossary (lowercase),
 
I’m referring to the general idea of a list of terms and definitions;
 

for example, glossary term means a term that appears in such a list.
 
When I use Glossary (with an initial capital), I’m referring to the
 

iBooks Author tool for creating, managing, and displaying glossary
 

lists, terms, and definitions, and to the Glossary interface that the
 

book’s readers see.
 

Learn How the Glossary Works 
To get a better handle on this tool, it helps to see how it works in 
iBooks from the reader’s point of view. When a reader taps a glossary 
word that the author has marked as such in the text, a popover like the 
one shown in Figure 65 appears. 

Figure 65: Tapping a glossary word in a Multi-Touch book on an iPad 
produces a popover that shows the term and its definition. 
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Tapping the Dictionary button in the popover shows the standard 
iBooks Dictionary popover, over which, as author, you have no control. 
A tap on the Glossary Index button, however, shows your book’s 
complete list of glossary terms, with the tapped-on term selected 
in the list and its details displayed in a large pane to the right 
(Figure 66). Unlike iBooks’ built-in Dictionary, you have complete 
control of the Glossary’s contents. 

Figure 66: The full glossary entry, and a list of the other entries. 

The glossary term’s details include the following: 

•	 Term: The glossary term itself (scholars often call this a lemma). 
You can edit this item in iBooks Author. 

•	 Definition: The term’s definition appears below the term in 
iBooks. In iBooks Author, you can replace the placeholder text 
with a definition of your own devising. 

•	 Related glossary terms: This list is composed of other entries 
in the Glossary that are related to the displayed term. If a reader 
taps a related term, iBooks displays that term’s details on the 
Glossary page. You can add and remove terms from this list in 
iBooks Author. 
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•	 Index: This list includes places in the book where, in most cases, 
the term occurs. A reader can tap an entry on this list to switch 
to that location in the book. However, it is quite possible to create 
an index link to a location where the term doesn’t appear. This 
capability is often used for conceptual index terms (e.g., the term 
Cell Division might link to a page where mitosis is described, but 
where the actual words cell division do not appear). 

The Primary Definition and the Index
 

You can specify that one of the items in a Glossary page’s list of 
Index locations is the Primary Definition. For example, in a book 
about movie composers, you may have index links to five occurrences 
of the name Bernard Hermann; you can then specify the Primary 
Definition to be the link to the place in your text where you discuss 
his film composing career (as opposed to mentions of him in relation 
to other film composers). 

A term in a book’s Glossary doesn’t need to have a Primary Definition 
in its Index list; that’s up to you to decide on a per-term basis. In 
fact, a Glossary term does not need to link back to the book’s text 
at all. If you want to fill your Glossary with terms and definitions and 
never link back to the text from any of them (that is, use your book’s 
Glossary as a simple, specialized dictionary), you can. 

Primary Definition links appear to the reader in bold type in the Index 
list. 

Add Terms to the Glossary 
iBooks Author provides several ways to add a term to the Glossary, but 
adding it from a selection is the most flexible method: 

•	 Add it from a text selection: Select a word (or multiple 
contiguous words) in the text, and then, on the Glossary Toolbar 
(Figure 67), click Add Term. (The Glossary Toolbar appears below 
the Format bar; choose View > Show Glossary Toolbar [Shift-
Command-E] if it isn’t present.) 

Figure 67: The left-hand side of the Glossary Toolbar, where you can 
add terms. 
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The selected text is bolded and the location is marked in the 
Glossary as the Primary Definition in the Index (see the sidebar just 
above, The Primary Definition and the Index). Adding a term from 
a text selection makes the selected text active: when the reader taps 
this text in your book, it displays the definition of the term in the 
Glossary popover. You can remove the bold formatting manually 
or change the formatting in other ways—for example, you might 
want to change the color or typeface. 

Tip: To modify how iBooks Author styles terms you add from text 
selections, change the definition of the character style Glossary 
Primary Definition. See the topic Use Styles (under Add and Format 
Text) in iBooks Author’s Help for information about modifying styles. 

After adding the term, you can edit the definition. To do so, click 
the term. Alternatively, click Glossary in the iBooks Author sidebar 
or click the Open Glossary button at the right end of the Glossary 
Toolbar. The Glossary editor opens with your new term selected 
(Figure 68). Edit the placeholder text for the new term to provide 
the correct definition. 

Figure 68: The Glossary editor in iBooks Author. 
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•	 Type it in the Toolbar: When you are not viewing the Glossary, 
you can type a term directly in the New Glossary Term field in the 
Glossary Toolbar, and then click Add Term. The word is added to 
the Glossary, but no Index link is created. You may wish to use this 
method if you are simply using the Glossary as a dictionary of terms 
and definitions without links. 

•	 Add it directly in the Glossary: In the Glossary editor, click the 
Add button above the term list on the left. A new untitled term 
appears, which you can edit. Use this method when you are building 
a simple dictionary or you need to add a conceptual term that 
doesn’t appear in the text. 

In the Glossary editor you can edit the spelling of terms, compose 
definitions, search the current list of terms, add or modify each term’s 
Index list (those places in the text the term links to), and build each 
term’s list of related terms. 

And speaking of the Index list... 

Create Indexes 
Your book’s readers can click an entry on a term’s Index list in the 
Glossary to go to where that entry is linked in the book’s text. You’ve 
already seen in the immediately preceding section how selecting text 
in your book and clicking Add Term creates a Primary Definition link 
in the Glossary, but how do you add subsequent occurrences of a term 
in your book to the term’s Index list in the Glossary? 

Here’s how to link subsequent occurrences: 

1. Do one of the following: 

‣	 In the Glossary entry for the term, at the top of the Index 
list, click the Find Term button (shown near the bottom in 
Figure 68, slightly earlier). A Find & Replace dialog appears. 

‣	 On any page in the book, choose Edit > Find > Find (Command-
F), and then type the term in the Find field of the Find & Replace 
dialog that appears. Click Next in the Find & Replace dialog. 

In either case, iBooks Author selects and displays the next 
occurrence of the term that it finds. If you start from the Glossary 
editor, that’s usually the first occurrence in the book. 
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2. When iBooks Author finds an instance of the term that you’d like to 
include in the index, on the right side of the Glossary Toolbar, from 
the Index Link For pop-up menu, choose the term you want to link 
the selected text with, and then click Add Link (Figure 69). iBooks 
Author applies the Glossary Secondary Definition character style to 
the selected text, and the text is hot-linked to the chosen term in the 
Glossary. 

Figure 69: Add an Index Link from selected text with this right-hand 
portion of the Glossary Toolbar. 

3. Continue clicking Next in the Find & Replace dialog and optionally 
clicking Add Link in the toolbar until you’ve found all instances of 
the term in the entire manuscript. 

Tip: Just as you can change the way iBooks Author formats Primary 
Definition links in your book by redefining the Glossary Primary 
Definition style, you can redefine the Glossary Secondary Definition 
style that is applied to the links you create with the Index Link For 
pop-up menu. 

Note: All Index Links are two-way and one-to-one—the text on the 
book page links to one, and only one, Glossary entry, and the link 
back to it from the Glossary appears once, and only once, in the 
Glossary entry’s Index list. This means that only one Glossary entry 
can link to any specific piece of text in your book. 

You can use the Index Link For menu to link any selected text in your 
book to a term in the Glossary. For example, one could link the word 
presentation in the text of a book to the Glossary term Keynote. Using 
the Index Link For pop-up menu in this way is how you can link a 
passage of text to a conceptual term that you have manually added to 
the Glossary: just select a small portion of the text that discusses the 
concept and link it to the term using the Index List For pop-up menu. 

Tip: When selecting text to link to a conceptual term in an index, 
select only a small portion, such as the first word, rather than the 
whole passage. If you select the entire passage, you won’t be able 
to create any other links to the Glossary from within the passage. 
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Similarly, you can use the Index List For pop-up menu to link to notes 
in the Glossary. For example, suppose your history textbook contains 
the phrase, Ich bin ein Berliner. You can create a Glossary entry with 
the term 26 June 1963 and write a definition that describes President 
Kennedy’s speech on that date and the jelly doughnut misconception 
surrounding it (see http://en.wikipedia.org/wiki/ 
Ich_bin_ein_Berliner#Jelly_doughnut_misconception). You can then 
link the German phrase to that entry, and, voilà, instant footnote. 

As the list of terms you add to the Glossary grows, and especially if 
you use the Glossary for definitions, annotations, and indexes, keeping 
track of which terms are used for what purpose can become a problem. 
However, you can use the Status column in the Glossary’s Terms list to 
alleviate the problem (Figure 70). Click the Status column heading in 
the Terms list to group terms sharing the same Status color. 

Figure 70: Use the Status column in the Glossary’s Terms list to 
categorize your terms. 

The good news is that it’s easy to apply a Status color to a term: hover 
over a term’s Status indicator to see the Status pop-up arrows and 
then choose a Status color from the menu. The bad news is that you 
can choose from only three colors: green, orange, or the default blue. 
(Hmm... glosses, notes, and index entries: three typical Glossary uses, 
three colors. Why, it’s almost as though Apple planned it this way.) 

Hovering is also how you see a pop-up menu indicator for entries in 
a term’s Index list—this list is found at the bottom of the right side of 
the Glossary editor. Use that menu to manage entries in the Index list, 
and to navigate to the linked term in the book (Figure 71). 

Figure 71: Make an Index link the Primary Definition, remove it, or 
jump to the linked text in the book with the Index list pop-up menu. 
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Relate Glossary Terms to One Another 
The Related Glossary Terms list is where you associate one term with 
another in the Glossary: in iBooks, the reader taps a term in the list to 
jump to the entry for that term. In iBooks Author, this list appears in 
the Glossary editor beneath a term’s definition. 

You have two ways to relate terms in iBooks Author: 

•	 One-way relationship: Drag a term from the Terms list to the 
Related Glossary Terms heading. This places the dragged term in 
the Related Glossary Terms list for the currently displayed term, 
creating a one-way relationship. 

•	 Two-way relationship: Drag one term over another within 
the Terms list. This places the dragged term on the target term’s 
Related Glossary Terms list, and it also places the target term on 
the dragged term’s list, creating a two-way relationship. 

Removing a term is even easier: just drag the term from the Related 
Glossary Terms list until you see a puff of smoke beneath your pointer, 
then release (Figure 72). Keep in mind that removing the term at 
either end of a two-way relationship removes both ends. 

Figure 72: Boom! goes the related term. 

Cross Reference Your Book
 

Often one part of a book will refer to another part. Such cross-
references in the print world usually consist of text like see page 47. 
However, in the digital world, including in this book, cross-references 
can be interactive: they can be a word or phrase that the reader taps 
to go to a destination elsewhere in the book. Or even out of the book. 

141 



            
                

           
          

         

        
       
        

           
           
            
            

That’s how this book works, too! Tap (or click) any of the blue 
text in this ebook to go to where it links to. (I describe this feature in 
the first bullet item under Basics, much earlier.) 

Link within Your Book 
iBooks Author offers linking capabilities by way of a Link Inspector 
(Figure 73). In iBooks Author, the cross-references to other places 
within your book are hyperlinks, and their destinations are bookmarks. 

Figure 73: The Link Inspector’s two faces: Bookmark pane (left) 
where you first set up a link’s destination, and the Hyperlink pane 
(right) where you make a hyperlink to the destination. 

Before you can create a cross-reference hyperlink that’s of any use, 
you must create a bookmark to serve as the hyperlink’s destination. 
The Link Inspector makes that easy: select the text you want for 
your destination, and click the Add button in the Link Inspector’s 
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Bookmark pane (or choose Insert > Bookmark). The bookmark 
appears in the Bookmark pane’s list, with a name that matches the 
selected text. 

You can rename the bookmark by double-clicking it and typing a new 
name. Changing the name does not affect the text at the bookmark’s 
location. 

Making a hyperlink is just as easy: 

1. Select the text you want to serve as the hyperlink. 

2. In the Hyperlink pane of the Link Inspector, click Enable as 
a Hyperlink, and then, from the Link To pop-up menu, choose 
Bookmark (or choose Insert > Hyperlink > Bookmark). 

3. From the Name pop-up menu, choose the name of the bookmark 
that you want to make the hyperlink’s destination. 

When text is made into a hyperlink, iBooks Author applies the 
Hyperlink character style to it; you can change that style’s definition 
if you want. 

iBooks Author also makes linking to a figure or widget a snap, since 
all figures and widgets, when created, are automatically made into 
bookmarks: 

1. Position your cursor anywhere in the text without making a 
selection, and then, in the Hyperlink pane of the Link Inspector, 
click Enable as a Hyperlink. When you don’t have any text selected 
and click that checkbox to select it, the Hyperlink pane looks like 
Figure 74, and iBooks Author inserts an automatic text figure 
reference at the cursor position. 
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Figure 74: Linking to a figure or widget. 

2. In the list of figures, click the one that you want to serve as the 
hyperlink’s destination. 

Narrow the number of figures listed: To restrict the list 
to figures in a specific part of the book, choose an item from the 
In pop-up menu. To restrict the list to specific types of widgets 
or illustrations, choose an option from the Style pop-up menu. 

The automatic figure reference is linked. 

Cross-references don’t just have to occur in the body text. You can 
make almost any text into a hyperlink (except text that already is 
linked as a hyperlink or a glossary index link). For example, consider 
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the objectives placeholder that often appears in section opening 
layouts (see Change a Section Layout). You can link each objective 
you put in that placeholder to a bookmark in the section, making 
the objectives list a sort of mini-Table of Contents. 

You can also use bookmarks and hyperlinks to make on-page endnotes 
for a section instead of using the Glossary as an annotation tool (see 
Create Indexes): type the note markers in your main text, and then 
make them into hyperlinks, assigning their destinations to the notes 
you have put (and bookmarked) at the end of the section. 

Link to Other Destinations 
In addition to figures and bookmarks, you can also make hyperlinks 
that take the reader out of the book: you can cross-reference the 
Internet from your book. 

Do you want to link to a Web page? Choose Webpage from the Link 
To pop-up menu in the Link Inspector’s Hyperlink pane, and type 
(or paste) a URL in the URL field that appears. The hyperlink you just 
created, when tapped in the book, opens the iPad’s Safari browser to 
the URL you specified. 

You can link to an email address by choosing Email Message from the 
Link To pop-up menu, and then supplying an address and subject in 
the fields that appear. When the reader taps the link, a pre-addressed 
message is created that the reader can compose and send from within 
the book. The email capability can be used in commercial textbooks, 
for example, to allow readers to send feedback to the publisher, or in 
self-published textbooks for students to send email to the author. 

Think of the children: Consider whether adding Web or email 
links is appropriate for your book’s target audience. In many cases, 
it’s not a good idea: do you want to let a bunch of third-graders loose 
on the Web? 

Surprise! The test is a lie. There is no test, even though I promised 
one at the beginning of this chapter. But aren’t you glad you studied? 

145 



          
              

             
             

          
       

             
         

          
         

    

           
          

          
       

             
          

              
            

          
          

  

           
           
       

   

  

              
            

    

          
         

Publish Your Book
 
Ecclesiastes may be overstating things with the claim that, “Of the 
making of many books there is no end,” but it’s true that you’re not 
done when you have finished writing your book and adding all of its 
assets and study aids. There’s still the small matter of getting it to 
its adoring public—or to those students with their iPads and shining 
morning faces, creeping like snails unwillingly to school. 

The good news and the bad news is the same news: Apple makes 
your publication choices easy. If you want to sell Multi-Touch 
books made with iBooks Author, you can do so only through Apple’s 
iBookstore. You can give them away through other channels, but 
only Apple can sell them. 

In this chapter I first offer important tips about how to Proof and 
Fine-Tune your book and show you how to Preview Your Book on 
an iPad. Next I cover how to Make Advance Reading Copies so you 
can obtain useful feedback from trusted associates. 

As you polish your book to a gemlike gleam, it’s time to get serious 
about the business of publishing—if you haven’t done so already: 
I tell you how to Obtain an ISBN, a unique number used to identify 
a published book; help you Decide If You Need an iTunes Connect 
Account, your gateway to Apple’s iBookstore; and ask you to 
Consider iTunes U, Apple’s free online course materials service for 
educational institutions. 

And, finally, I guide you through the last step, in which you Prepare 
an iTunes Store Package and get ready to launch your creation to 
the delight and astonishment of the book-reading world. 

Fame and fortune awaits.
 

Proof and Fine-Tune
 

When the last word goes in, the last widget gets nailed down, the last 
cross-reference is linked, and the last glossary term is indexed, it sure 
feels like you’re done. 

But you’re not. As countless writers, editors, publishers, and readers 
have empirically demonstrated over the centuries, there’s always one 
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more typo. And not just typos: in even the best constructed drafts 
(and at this point, you’ve not finished a book, you’ve finished a draft 
of a book), there can be other sins of omission and commission that 
you may be unable to spot because you’re too close to the material, 
having spent weeks or months composing it. 

With the bulk of the work behind you, I recommend you do these three 
things to apply the final polish before publication: 

•	 Fine-Tune the Table of Contents (discussed next). 

•	 Preview Your Book and do a sanity check. 

•	 Make Advance Reading Copies in order to beta-test the book with 
a small group of readers. 

Let’s take a closer look at each of these. 

Fine-Tune the Table of Contents 
Way back in Plan Your Book, I talked about why you should keep your 
book outline shallow. One reason was that iBooks Author includes only 
the titles of chapters and sections in the Table of Contents. 

Well, that is true except for one special case: you can go deeper 
than two levels in the alternate portrait view Table of Contents for a 
Landscape with Portrait book. Look at the TOC pane of the Document 
Inspector (Figure 75), and you’ll see a list of paragraph styles— 
paragraphs formatted with those styles are included in the alternate 
portrait view’s Table of Contents. 
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Figure 75: The TOC pane of the Document Inspector is where you 
add or remove Table of Contents items. 

Any paragraph that has one of the listed paragraph styles assigned to 
it appears in the alternate portrait Table of Contents as a sub-section 
heading. Keep in mind, however, that where a paragraph style appears 
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in the TOC pane’s list does not imply that style’s nesting level in the 
Table of Contents. All paragraph styles listed in the pane appear at 
the same level in the alternate portrait Table of Contents. 

The upshot? You really have only three levels of Table of Contents 
nesting available in a Multi-Touch book (and the third only in the 
alternate portrait Table of Contents of a Landscape with Portrait 
book). But that’s more than two, and that extra level of TOC-goodness 
is more apt to be useful for the reader who is reading the book in its 
alternate portrait view than in the landscape view where the reader 
can see thumbnails of each and every page. 

Although that extra level is not worth stressing about while you’re in 
the throes of active composition, once that stage ends, it’s a good time 
to go through your book and choose sub-sections that merit treatment 
as third-level Table of Contents entries for the alternate portrait view. 

Preview Your Book 
You can preview your book at any stage of the book building process, 
but if you don’t do it at any other time (and you might not if you don’t 
have ready access to an iPad), you should preview it when all the pieces 
of your book are in place. After all, although iBooks Author does give 
you a good idea of what your book will look like and how it will act, it 
doesn’t provide a perfect simulation of your book running in iBooks 
on an iPad. For that, you need to have, well, iBooks on an iPad. 

You’ll also need your connector cable to attach your iPad to your 
Mac: you can’t send a book preview wirelessly to an iPad with iBooks 
Author. 

Here’s how to put a preview of your book into iBooks on your iPad: 

1. Connect your iPad to your Mac, and open the iBooks app. If your 
iPad starts to sync with iTunes, wait for it to finish syncing before 
taking the next step. 

2. In iBooks Author, on the Toolbar, click Preview. You may see 
a reminder from iBooks Author to make sure the iPad is connected 
and iBooks is open on it. If so, dismiss the dialog; otherwise, make 
sure the device is connected, iBooks is open, and the iPad is not 
sleeping. 
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Note: If you’ve connected more than one iPad to your Mac, you see 
a dialog where you can select the iPad that receives the preview. 

There is no step three. iBooks Author prepares a preview version of 
your book and transfers it to the connected iPad. After a while (it can 
be a few minutes if you have a big book with lots of media and an older 
iPad), your book opens on the iPad to the page on which you were last 
working. 

Tip: You can also create a preview with a menu command: File > 
Preview. And the keyboard shortcut Command-Option-P is available, 
too, if you want instant access to the Preview command. 

Once the preview is on the iPad, you can disconnect the iPad from your 
Mac. The preview stays on the iPad, so you don’t have to be tethered 
to your Mac to view it. You can even close your book and open another 
one; the preview remains on the shelf of the default Books collection in 
iBooks (Figure 76), so you can open it again when you like. 

Figure 76: A preview book, on the shelf in iBooks, suitably badged 
and available for proofing. 
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Previewing a single section: Choose File > Preview Current 
Section Only to send a preview of the currently selected section 
of your book to your iPad. The currently selected section is the one 
where the insertion point is located or where an item or some text 
is selected. Previewing individual sections can speed things up, 
especially when you have a big book with many sections and lots 
of widgets and other media, because much less data has to be 
transferred to your iPad. 

You can use iBooks Author’s General Preferences to choose whether 
the Preview command on the toolbar and the Command-Option-P 
keyboard shortcut previews the entire book or the current section. 
Whichever preview method you make your default, though, you can 
still choose the other method from the File menu. 

Use Note-taking in iBooks to Track Problems
 

When you perform a final proofing pass over your book’s content 
with a preview on an iPad, you can use iBooks’ note-taking features 
to mark any problems you spot: touch and drag a highlight over the 
problem area, release your finger, and then tap again to access the 
highlight/note popover. Tap the Note button, type your note, and then 
tap the screen outside the note. 

Later, back at your Mac with the marked-up preview to consult on 
the iPad beside you, you can use iBooks Author to sand down your 
vessel of knowledge’s remaining rough patches. To review your notes 
quickly on the iPad, tap the Notes icon on the book’s toolbar (if the 
toolbar isn’t showing, tap near the center of a page to reveal it). 

There’s never more than one preview copy of a particular book on 
an iPad. Whenever you preview your book with iBooks Author, the 
previous preview copy of that book, if any, is updated. Even if you 
move a preview to a different collection in iBooks, iBooks Author finds 
it and updates it. 

Note: There is no way to transfer a preview from iBooks to another 
iPad. In the past, I’ve suffered from problems of galloping versionitis 
with multiple versions of proof copies of multimedia books hanging 
around, so I welcome Apple’s one-iPad-one-proof implementation. 
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Make Advance Reading Copies 
This may not be the Prime Directive for authors, but it is an important 
axiom: You are not your readers. How can you be? You are one person; 
they are (you hope) many. Moreover, they haven’t yet read your book, 
while you have read it so often that you can quote swaths of its text in 
your sleep. Your readers have fresh eyes and varying expectations. 

To make sure that the pellucid prose and cogent explanations in your 
book are pellucid and cogent for other people, you have to let other 
people read your book. That’s where a time-honored technique from 
print-publishing comes in: advance reading copies (known as ARCs in 
the publishing trade). 

To produce a full interactive copy of your book that you can distribute 
to your advance readers (whether by local network, Internet-based 
shared storage systems like Dropbox, as an email attachment, or some 
other method), do this: 

1. Choose File > Export. 

2. In the dialog that appears (Figure 77), click iBooks. 

Figure 77: You can export your book as a complete iBooks book, 
a sample iBooks book, a non-interactive PDF, or as a text file. 
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3. Choose whether you want to export the full book, or a sample 
suitable for uploading to the iBookstore. You can, optionally, give 
the book a version number (this last comes in handy after your 
book is published and you want to publish an update). 

4. Click Next. 

5. In the standard file dialog that appears, specify a local or network 
storage location for the file, and then click Export. 

Note: You can add an exported Multi-Touch book to an iPad just like 
you can any other ebook: drop it in iTunes and sync it to your iPad, or 
use the Open In capability of mobile Safari, the Mail app, or another 
network application, like Dropbox, to get it into iBooks. 

A complete copy of the Multi-Touch book is the best one to give to 
your chosen advance readers if you want reviews of the book with all 
of its features. However, because the full book is the one most likely 
to be pirated, and because distributing advance copies increases your 
exposure to such pilferage, iBooks Author allows you to protect 
exported Multi-Touch books with a password. 

Do this before you export your book: 

1. In the Document pane of the Document Inspector, click Require 
Password to Open. 

2. In the dialog that appears (Figure 78), specify a password and an 
optional hint for the forgetful reader. 

Figure 78: Protect your ARCs with passwords before you export 
them. 
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3. Click Set Password. 

The password is assigned, and when you export the book the exported 
copy won’t open until the reader supplies the correct password. 

Keep track of your passwords! You can’t change or remove the 
password of a book in iBooks Author unless you know the password. 
When you assign a password to a book, make a note of it somewhere. 

Here are a couple of suggestions about ARCs and advance readers: 

•	 Choose a small, select group as advance readers: You can 
get a lot of useful feedback from a few involved, intelligent readers. 
Choose just a handful of people. It makes both collecting feedback 
and keeping track of your reviewers easier, and it reduces the 
chances of piracy of your content. 

•	 Try PDF or text exports for some readers: You may know of 
an intelligent and helpful person who would be a great candidate to 
receive an ARC, but woefully that person is without an iPad. Such a 
person can still review much of your book’s content from a PDF or 
text export. Lower-bandwidth exports are also good when you want 
to get reviews of your text before the interactivity is all in place. 

Note: The view you choose in iBooks Author affects PDF exports. 
That is, if you have the book displaying the portrait view, the 
exported PDF will reflect its layout; if you have the landscape view 
displayed, that’s the layout used for the PDF. 

Obtain an ISBN
 

In its most basic sense, publishing means to make something public, 
and you can do that with any Multi-Touch book you make with iBooks 
Author: just put it on an Internet-connected server somewhere and tell 
people, “Here it is, come and get it!” 

On the other hand, if you want to distribute your book for free through 
many established ebook distribution systems or place it in libraries, 
your book needs an ISBN. The ISBN is the International Standard 
Book Number that book distributors and retailers use to keep track 
of their wares. The ISBN identifies your book uniquely: every different 
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edition or format of a printed book (e.g., paperback or hardcover), and 
every different version or edition or format of a published ebook (e.g., 
Kindle or EPUB), requires a unique ISBN that is not shared with any 
other published work. 

Note: The iBookstore doesn’t require that your book have an ISBN, 
but Apple nonetheless recommends it have one. 

Usually, your publisher worries about the ISBN, and you, as author, 
need not concern yourself. However, if you are about to enter the world 
of self-publishing, read on. 

First, ISBNs may or may not be free. You get them from the ISBN 
agency assigned to the country where the book is to be published (see 
http://www.isbn-international.org/agency for a list of ISBN agencies 
for various countries). In the United States, the agency is the U.S. ISBN 
Agency, run by Bowker (http://www.isbn.org/), and Bowker charges. 

Buying a single ISBN is not cheap; the current U.S. price is $125. 
However, the price per individual number plummets when you buy 
in bulk as most publishing firms do: they’re only a dollar apiece when 
you buy a thousand at a time. Bowker’s Identifier Services (https:// 
www.myidentifiers.com/isbn/main) provides for online ISBN 
purchases. 

Don’t be fooled! If anyone offers to sell you an ISBN at cut-rate 
prices, don’t listen. Only the authorized ISBN agency for your country 
can distribute them legitimately. 

The U.S. ISBN Agency provides several FAQs and PDFs about ISBNs 
at http://www.isbn.org/standards/home/about/faqs_main.html. I 
recommend that you look them over. 

Note: Even though the iBookstore doesn’t require an ISBN, you 
do need one if you want your book to be listed in Books in Print, 
the authoritative bibliographic reference for currently available books 
(Books in Print is published, not at all coincidentally, by Bowker). 
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Set Up an iTunes Connect Account (If You 
Need One) 

iTunes Connect is Apple’s online service through which you manage 
uploads of content that you are distributing through Apple’s 
iBookstore. Only people who either own or control content intended 
for digital distribution, or their authorized representatives, can apply 
for and receive such accounts. 

Applying for an iTunes Connect account can take some time, so don’t 
leave it for the last minute. For example, Apple currently requires that 
you have an Apple ID account that’s set up for use on the iTunes Store 
and that is linked to a credit card. If you plan to sell your book (not just 
give it away for free), you’ll also need a U.S. Tax ID even if you are 
located outside the United States. 

Note: In some cases, you may need to create an new Apple ID just 
for using with iTunes Connect, even if you already have one; I didn’t 
have to create a new one, but several colleagues of mine have. 

Read the FAQ: For a quick iBookstore orientation in the guise of an 
FAQ, read the Book Publishers: Frequently Asked Questions page at 
http://www.apple.com/itunes/content-providers/book-faq.html. 

Decide If You Need an iTunes Connect Account 
Before you concern yourself with setting up an iTunes Connect 
account, you need to determine if you need one. 

If you intend to give your ebook away for free, you can use any of the 
informal distribution methods that I mentioned earlier in this chapter, 
in Make Advance Reading Copies. In that case, you do not need an 
iTunes Connect account, nor any formal affiliation with Apple. 
However, if you want to make your book available at no charge in 
Apple’s iBookstore then you—or your publisher—need an iTunes 
Connect account. 

Furthermore,Apple’s iBookstore is the only place you can sell Multi-
Touch books made with iBooks Author: that’s stipulated in the license 
agreement that accompanies iBooks Author (you did read it, didn’t 
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you?). So, if you intend to sell your book, you—or your publisher— 
must hook-up with Apple’s virtual media bazaar. 

If your book has a publisher: If some other entity will be 
publishing your ebook, then what I say below about the iBookstore 
may be almost completely for your amusement only, since your 
publisher (or, in the case of iTunes U, your educational institution’s 
iTunes U Project Manager) has the responsibility for handling the 
digital paperwork and the submission of materials to the iBookstore. 

Consider iTunes U
 

iTunes U (http://www.apple.com/education/itunes-u/) is Apple’s 
instructional media distribution service that partners with K-12 and 
higher education teachers and institutions. Educational partners 
can prepare entire courses for delivery through iTunes U, or make 
a collection of digital materials available for a course. If you are 
developing a free Multi-Touch textbook for use with your own classes, 
or for classes offered by your institution, iTunes U is a good place 
to publish without having to go through iTunes Connect and the 
iBookstore. Don’t believe me? iTunes U has had over a billion content 
downloads since its creation. 

To put your free book on iTunes U for just your own class, you 
need to create a course on iTunes U, and for that you need an 
Apple ID to log in to Apple’s iTunes U Course Manager (https:// 
itunesu.itunes.apple.com/coursemanager/). This Web-based tool 
is very easy to use; a short video tutorial (http://www.apple.com/ 
education/resources/videos/#itunes-u-course-manager) may be 
all you need to get started. Nonetheless, I suggest you read the 
Creating Your Course PDF (http://www.apple.com/support/itunes-u/ 
docs/iTunesU_CourseCreation_0812.pdf) from Apple, which provides 
more detail about how to create and manage a course. 

Anyone can set up an iTunes U course that can enroll as many as 
50 students. However, if you work for an institution that has a public 
iTunes U site, you can submit your course to the iTunes U Catalog 
that appears in the iTunes U section of the iTunes Store. 

If you want to publish your book through the iBookstore, whether 
free or not, so that other iTunes U courses can use it, you must do 
that through your iTunes Connect account. 
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Apply for an iTunes Connect Account 
You can apply for an iTunes Connect book distribution account at 
https://itunesconnect.apple.com/WebObjects/iTunesConnect.woa/ 
wa/bookSignup. Once you have logged in to your iTunes Connect 
account, you can (and should—because it’s easier now than it will be 
later) download iTunes Producer, the Mac application that you need 
in order to upload your book to the iBookstore. You can find a link 
to that software in the Deliver Your Content section of the iTunes 
Connect site. 

When you apply for an account, you must choose whether you want 
a Free Books Account or a Paid Books Account. Which one you choose 
is important, because you can’t convert one type of account to another: 

•	 If you only ever want to produce books that you give away, choose 
the Free Books Account: there’s less virtual paperwork involved. 

•	 On the other hand, if you can imagine that you may, someday, 
want to sell a Multi-Touch book through the iBookstore, choose 
the Paid Books Account. Although you must provide banking and 
tax information to set up a Paid Books Account, you can use that 
account both to sell books and to give them away, so all your bases 
are covered. 

Prepare an iTunes Store Package (If You 
Need One) 

An iTunes Store package is the final “file” that you upload to the 
iBookstore. (If you are giving your book away for free, but not through 
the iBookstore, you don’t need to create an iTunes Store package.) 
You create an iTunes Store package when your book is fully complete 
and fully tested, although you can try running through the process at 
any time. 

To prepare the iTunes Store package: 

1. In iBooks Author, choose File > Publish (Command-Shift-P), or 
click Publish on the Toolbar. 

You see the Publish dialog as in Figure 79. 
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Figure 79: The Publish dialog is the first step in publishing your 
book. 

A good time to learn more: Click the Learn More about 
Publishing to the iBookstore link in the Publish dialog to see 
Help topics related to publishing. They provide useful information, 
such as the current file-size limits for Multi-Touch books in the 
iBookstore (2 GB at the moment) and how to make sample books. 

2. Click Continue, and follow the prompts. The Publish dialog walks 
you through the following steps: 

‣	 Checking the book for errors. This check is made automatically. 

‣	 Signing in to your iTunes Connect account. You fill in the Apple 
ID for your iTunes Connect account and its password. You must 
have an iTunes Connect account to publish a book with iBooks 
Author. 

‣	 Specifying whether the book is a new one or an update to a 
previously published book. 

‣	 Creating a downloadable sample book. You can choose the 
chapter from which the sample is taken, or create one manually. 
Automatically generated samples can contain up to 15 pages 
from your book. 

‣	 Exporting the book and optional sample. This step creates 
a .itmsp package that contains the book, the sample (if any), 
some XML related to the book, and a cover file. The package 
is stored in the same folder as your iBooks Author file. 
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‣	 Launching iTunes Producer using the data that iBooks Author 
created. 

If you have iTunes Producer installed, iBooks Author automatically 
launches it after it saves your book’s iTunes Store package, and hands 
iTunes Producer the package so it can access the information from the 
XML file (Figure 80). If you haven’t yet installed iTunes Producer, as 
I suggested earlier, you are given the opportunity to download a copy 
during the publication process described above. 

Figure 80: The first of many screens you need to fill out in iTunes 
Producer when you submit a work for publication. 

Note: If you don’t want to submit the book when iTunes Producer 
opens, just close it. You can always open iTunes Producer later by 
double-clicking the .itmsp file. 
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Filling out the fields on the many screens in iTunes Producer can be 
daunting. However, if you launch iTunes Producer manually, you see 
a Help button on the startup screen. Click that to open the iTunes 
Producer online manual in your Web browser. This guide documents 
all the fields you need to fill out. (If only it were available as a Multi-
Touch book…) 

Once you fill in all the necessary data in iTunes Producer, you “deliver” 
the book to your iTunes Connect account on the last screen of iTunes 
Producer. Check your data carefully as you enter it: if you miss any 
required fields or enter incorrect data (such as a too-long description), 
iTunes Producer balks until you fix the problem. 

It’s possible that, even after iTunes Producer has delivered your book, 
Apple may reject it for some reason or another. Don’t be afraid to push 
back if their requests seem excessive—several Take Control ebooks 
have been rejected for trivial reasons but were accepted after we 
explained our position clearly. And although it’s unlikely, Apple does 
reserve the right to refuse to publish an iBooks Author ebook for any 
reason they so wish. Arbitrary, yes, but it’s Apple’s walled garden, so 
Apple gets to set the rules. 

After you’ve uploaded everything, it can take as long as a week (or even 
more) before your book appears for sale or download. 

Warning! Once a book appears in iTunes Connect, you can make 
certain changes, such as temporary pricing changes for a sale, on 
the iTunes Connect Web site. Be careful, however, because uploading 
a new copy of the book from iTunes Producer can overwrite the 
changes you’ve made on the iTunes Connect site. 

In addition, when you resubmit a book with new files using iTunes 
Producer, those files replace the files you see on the iTunes Connect 
site. However, any changes you make to the resubmitted book’s 
metadata on the first screen in iTunes Producer aren’t updated on the 
site. Instead, you must make those changes on the iTunes Connect site 
itself (some changes you make in iTunes Producer, like pricing data, 
do come through to iTunes Connect). 

Bottom line: Always verify that the iTunes Connect site’s data is 
correct after you submit changes via iTunes Producer. 
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I won’t go deeper into the details of the iBookstore publication process 
in this book. Apple’s online stores, and the requirements and methods 
for selling or distributing through them, are continually evolving, and 
Apple’s textbook publication initiative, which is only a little over a year 
old as I write this, continues to change as Apple fine-tunes its strategy 
for this new enterprise. 

Now get to work, and may all of your books be bestsellers! 
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About This Book
 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments at 
tc-comments@tidbits.com. 

Ebook Extras
 

You can access extras related to this ebook on the Web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and—usually— 
Mobipocket. (Learn about reading this ebook on handheld devices 
at http://www.takecontrolbooks.com/device-advice.) 

•	 Read postings to the ebook’s blog. These may include new 
information and tips, as well as links to author interviews. At the 
top of the blog, you can also see any update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by 
following the directions that appear when you click the “access 
extras…” link above. Then, once you are logged in to your new 
account, add your ebook by clicking the “access extras…” link a 
second time. 

Note: If you try the directions above and find that the device you’re 
reading on is incompatible with the Take Control Web site, contact us 
at tc-comments@tidbits.com. 
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Copyright and Fine Print
 
Take Control of iBooks Author 

ISBN: 978-1-61542-403-0
 
Copyright © Michael E. Cohen, 2013. All rights reserved.
 

TidBITS Publishing Inc.
 
50 Hickory Road
 

Ithaca, NY 14850 USA
 
http://www.takecontrolbooks.com/
 

Take Control electronic books help readers regain a measure of control in an oftentimes 
out-of-control universe. Take Control ebooks also streamline the publication process so 
that information about quickly changing technical topics can be published while it’s still 
relevant and accurate. 

This electronic book doesn’t use copy protection because copy protection makes life 
harder for everyone. So we ask a favor of our readers. If you want to share your copy of 
this ebook with a friend, please do so as you would a physical book, meaning that if your 
friend uses it regularly, he or she should buy a copy. Your support makes it possible for 
future Take Control ebooks to hit the Internet long before you’d find the same information 
in a printed book. Plus, if you buy the ebook, you’re entitled to any free updates that 
become available. 

You have our permission to make a single print copy of this ebook for personal use. Please 
reference this page if a print service refuses to print the ebook for copyright reasons. 

Although the author and TidBITS Publishing Inc. have made a reasonable effort to ensure 
the accuracy of the information herein, they assume no responsibility for errors or 
omissions. The information in this ebook is distributed “As Is,” without warranty of any 
kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person or entity 
for any special, indirect, incidental, or consequential damages, including without 
limitation lost revenues or lost profits, that may result (or that are alleged to result) from 
the use of these materials. In other words, use this information at your own risk. 

Many of the designations used to distinguish products and services are claimed 
as trademarks or service marks. Any trademarks, service marks, product names, or named 
features that appear in this title are assumed to be the property of their respective owners. 
All product names and services are used in an editorial fashion only, with no intention of 
infringement of the trademark. No such use, or the use of any trade name, is meant to 
convey endorsement or other affiliation with this title. 

This title is an independent publication and has not been authorized, sponsored, 
or otherwise approved by Apple Inc. Because of the nature of this title, it uses terms that 
are the trademarks or that are the registered trademarks of Apple Inc.; to view a complete 
list of the trademarks and of the registered trademarks of Apple Inc., you can visit 
http://www.apple.com/legal/trademark/appletmlist.html. 
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Featured Titles
 
Click any book title below or visit our Web catalog to add more 
ebooks to your Take Control collection! 

Take Control of iCloud (Joe Kissell): Understand the many features, 
get set up properly, and enjoy iCloud! 

Take Control of Mail on the iPad, iPhone, and iPod touch (Joe Kissell): 
Develop your mobile email strategy, and learn how to use email 
effectively on your handheld Apple devices. 

Take Control of Maintaining Your Mac (Joe Kissell): Find a 
commonsense approach to avoiding problems and ensuring that your 
Mac runs at peak performance. 

Take Control of Making Music with GarageBand ’11 (Jeff Tolbert): 
Combine your creativity with GarageBand’s editing and mixing 
techniques to compose tunes that please the ear! 

Take Control of Recording with GarageBand ’11 (Jeff Tolbert): Create 
musical compositions with vocals, drums, guitars, and even the kitchen 
sink! 

Take Control of PDFpen 5 (Michael E. Cohen): Learn to create, edit, 
and manipulate PDFs with Smile’s PDFpen 5! 

Take Control of Safari 6 (Sharon Zardetto): Make the most of Apple's 
Safari, a Mac Web browser with hidden and under-appreciated talents! 

Take Control of Scrivener 2 (Kirk McElhearn): Write your screenplay, 
novel, or dissertation with the author-focused features in Scrivener! 

Take Control of TextExpander (Michael E. Cohen): Whether you want 
to type faster or you already use TextExpander but want to harness its 
power more fully, let Michael lead you to typing nirvana. 

Take Control of Your iPad (Tonya Engst): Optimize your iPad 
experience—make important customizations, sync media and data, and 
get tips on making the most of core iPad apps. 

Take Control of Your Passwords (Joe Kissell): Overcome password 
overload without losing your cool—and view the comic that goes with 
this ebook! 
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